Bug 248792 - String "-" should be untranslatable
String "-" should be untranslatable
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 16:02 EDT by Gauthier Ancelin
Modified: 2009-09-21 17:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 03:27:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gauthier Ancelin 2007-07-18 16:02:18 EDT
Description of problem:


It seems the string "-" should be untranslatable:

#: ../src/vmm-add-hardware.glade.h:1 ../src/vmm-create.glade.h:3
msgid "-"
Comment 1 Cole Robinson 2008-03-12 17:11:38 EDT
This is fixed upstream:

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=cec4f3d4edbb
Comment 2 Piotr Drąg 2008-03-14 15:59:14 EDT
I'm happy to see these strings removed from po files, but unfortunately you made
untranslatable some strings that have to be translated, like:

Virtual Machine Manager
80 MB of 1 GB
30 MB of 128 MB
example.com
1.59 GB of 2.2 GB

Some languages may need more strings to translate ("60%", "2000 MB"?), but I'm
not sure with this.
Comment 3 Cole Robinson 2008-03-14 16:28:14 EDT
Hi, I'm glad you reviewed this change.

The 'Virtual Machine Manager' string is indeed an error, I will fix that.

The others aren't though. They are actually strings the user never sees: they
are hardcoded into the graphics of the application as a kind of default value.
It helps us to see what is supposed to be in a graphical label when we are
editing the graphics. Labels with no text are not easily discernable or
selectable. As such those strings do not need to be translated, because when the
application is initialized the default values are (ideally) either overwritten
or removed outright.
Comment 4 Piotr Drąg 2008-03-14 16:49:11 EDT
Thanks for your explanation and fast reply!
Comment 5 Cole Robinson 2008-03-14 18:35:11 EDT
Fyi that message is now fixed.

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=e6d2bd613aec
Comment 6 Bug Zapper 2008-05-13 23:05:06 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Fedora Update System 2008-12-01 13:10:44 EST
virt-manager-0.6.0-0.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/virt-manager-0.6.0-0.fc9
Comment 8 Fedora Update System 2008-12-01 13:22:38 EST
virt-manager-0.6.0-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/virt-manager-0.6.0-1.fc9
Comment 9 Fedora Update System 2008-12-02 20:29:24 EST
virt-manager-0.6.0-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-10705
Comment 10 Fedora Update System 2008-12-21 03:26:24 EST
virt-manager-0.6.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.