This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 248794 - Upgrade of FC6 to F7 hangs if the FC6 was installed on 3 separate partitions
Upgrade of FC6 to F7 hangs if the FC6 was installed on 3 separate partitions
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 16:08 EDT by Henrik Johansson
Modified: 2008-06-16 21:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:54:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrik Johansson 2007-07-18 16:08:30 EDT
Description of problem:
Upgrade of FC6 to F7 hangs if the FC6 was installed on 3 separate 
partitions /boot, / and swap (the FC6 was updated by yum). 
Original install was FC3 or FC4, upgraded to FC5 and FC6.

Version-Release number of selected component (if applicable):
FC6 upgrade to F7

How reproducible:
Has tested this on 2 different computers.

Steps to Reproduce:
1. Install FC3-4, on 3 separate partitions.
2. Update the OS with yum and upgrade in steps to FC6.
2. Update FC6 with yum.
3. Boot from the F-7-i386-rescuecd and use an NFS-partition as source.
4. Start the upgrade (the upgrade hangs in different packages).
5. Stopped the upgrade and rebooted, it was working with the same package, 
   for more than 2 hours.

  
Actual results:
The FC6 booted, even if more than 400 packages was updated.

Expected results:


Additional info:
I tried to install instead of upgrade, it gave the same problem.
Installation with default partitioning, was OK on both computers.
An upgrade of an FC6, that was installed, with / and swap in a 
volume-group, was OK.
Comment 1 Jeremy Katz 2007-07-25 16:35:42 EDT
Where does it hang?  When it hangs, can you still switch ttys?
Comment 2 Henrik Johansson 2007-07-27 17:26:49 EDT
It hangs in installation of a software package.
I haven't tried to switch tty, didn't know about that option.
BR
Henrik
Comment 3 David Cantrell 2007-09-11 17:13:23 EDT
How much memory do you have?  Less than 256MB of memory and you're asking for
trouble.
Comment 4 Henrik Johansson 2007-09-12 14:57:32 EDT
In the Presario 5670 is it 384MB of memory.
From dmesg on the OptiPlex GX1:
0MB HIGHMEM available.
639MB LOWMEM available.
Comment 5 Bug Zapper 2008-05-14 09:35:40 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2008-06-16 21:54:41 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.