Bug 2488 - Red Hat Install Expereince : Failed, Totally Frustrating
Red Hat Install Expereince : Failed, Totally Frustrating
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-02 22:15 EDT by adamh
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-04 14:44:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description adamh 1999-05-02 22:15:05 EDT
Having worked on S390 mainframes, SMP NT servers and now
most recently SUN solaris I decied to try out red hat v5.0
on my home PC. Bad idea.

I make up the install and supp iamge disks no problem. I
decided to blow away my FAT32 10.2 gig partition and make a
new one at 80%, with 127 meg UNIX swap as my system has 128
meh ram and the left as a / root mount point.

I read all relevant docos before starting that came with
your Red Hat CD. I find that disk druid wont do FAT32
partitions. I exit and do a dos floppy boot to make the 80%
primary fat32 partition. I rerun the red hat install.

For some undocumented reason I find that I cannot allocate
all the available space to the root mount. It was around
1.5 gig free and disk druid would only do a fraction even
with the growable flag.

I decide not to worry about this and just go with it. I am
then greeted with a message saying that I dont have a unix
swap partition defined when I did have a 127 meg unix swap
defined in disk druid with the correct type as unix swap.

I exited from the install and decided to go back to the dos
floppy boot to put in a few simple fat16 partition thinking
that disk druid wasnt happy with the fat32.

I find that fdisk thinks I have extended partitions with
logical drives. I cant delete the extended partition
because fdisk says that a logical drive exists. I try to
delete a logical drive in the extended partition but fdisk
no says there isnt one!!! I reboot the unix install
procedure and disk druid can no longer read the media. The
fdisk option inside the red hat install doesnt do anything
and when selecting the edit option the screen flashes and I
go nowhere.

I then spend two hours online on a real computer running
windows to discover some undocumented fdisk commands that
forces fdisk to create a logical drive in the extended
partition, and then just deleted it to undo what disk druid
did to my partition table.

Feeling impressed that I fixed this, I retry the red hat
UNIX install for the Nth time. I had a fat16 primary
partition and used disk druid to create a root mount and a
unix swap partition. Again I was greeted with a message
saying I handt allocated swap disk space when I had.

This time I ignored it and went ahead. The system went into
fomratting the drive. After a long wait it said that it
couldnt mount the drive!! Then when I tried to reboot a dos
floppy the dos version fdisk had the old problem of
extended logical drives defined but not existing!!

Fixing this using the dos fdisk force command I retried the
Linux install using disk druid. Same error, cant mount.

After spending hours on this lame product I gave up and
reinstalled windows 98, which actually works. God help
those who have basic windows knowlede, because with my
expert level NT knowledge and reading your docos I wasnt
able to get it installed, Disk druid, fdisk and your
install routines are full of bugs.

If you expect people to migrate from windows youve got to
make it a hell of alot easier. The reason I tried your
product was I wanted to see what the hype is all about, but
so far I havent seen anything of value.
Comment 1 David Lawrence 1999-05-04 14:44:59 EDT
Sorry for the difficulties that you had. Most if not all of the
problems that you have mentioned have been addressed in our latest
version 5.2 and now 6.0 which will be released in about a week. I feel
you will have much better luck with these newer improved releases than
with the older 5.0. The newer versions can be purchased from us or
from www.lsl.com, www.linuxmall.com, or downloaded from
ftp.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.