This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 248813 - No libpcap.a in libpcap / libpcap.devel
No libpcap.a in libpcap / libpcap.devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libpcap (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 18:40 EDT by Eduard Vopicka
Modified: 2010-04-23 04:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 06:07:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eduard Vopicka 2007-07-18 18:40:22 EDT
Description of problem:

There is no libpcap.a in libpcap/libpcap.devel


Version-Release number of selected component (if applicable):

[root@vel SPECS]# rpm -qa|sort|grep ^libpcap
libpcap-0.9.5-1.fc7
libpcap-devel-0.9.5-1.fc7
[root@vel SPECS]# 


How reproducible:


Steps to Reproduce:
1. rpm -ql libpcap | grep libpcap\\.a
2. rpm -ql libpcap-devel | grep libpcap\\.a
  
Actual results:

libpcap.a not found

Expected results:

libpcap.a found

Additional info:

Consequently, ssldump 0.9b3-143 fails to build because of configuration script
looks for libpcap.a...

Very quick workaround to allow ssldump to build is >/usr/lib/libssl.a :-) to
make ssldump's autoconfiguration script happy and ssldump then happily builds
with libpcap.so. But this is not very nice and there is no chance to build
statically linked ssldump binary.
Comment 1 Miroslav Lichvar 2007-07-19 06:07:53 EDT
Fedora Packaging Guidelines strongly encourage not to ship static libs unless a
compelling reason exists (http://fedoraproject.org/wiki/Packaging/Guidelines).

The ssldump configure script should be fixed instead.
Comment 2 Eduard Vopicka 2007-07-19 07:26:46 EDT
Hello.

In that particular case, I can agree that ssldump's configure script should be
fixed, because of it is broken logic to check for .a file and then build
dynamically with .so.

I must also respect that there will be less and less static libraries shipped
with Fedora distribution.

On the other hand, the fact that static libraries are unavailable with Fedora,
is IMHO no good. Having -static packages as mentioned in the document referenced
by you would do much better. In fact, if you have some really huge software
project that produces huge and comlex executables consisting mainly of
application code, then statical linking does not add relatively much to them and
statically linked binary is the best way to get application running on more
systems, where single and small upgraded .so can break your the application
completely. (Of course, there are also known disadvantages of statical linking.) 

And just for fun, here is a little snapshot taken on my small home installation
of F7. :-)

Brgds,

Ed

[root@vel tmp]# date
Thu Jul 19 12:19:29 CEST 2007
[root@vel tmp]# for a in `ls  /usr/lib/*.a`; do p=`rpm -qf $a`; echo "$a $p";
done | grep \\.fc7$
/usr/lib/libasound.a alsa-lib-devel-1.0.14-0.4.rc3.fc7
/usr/lib/libaudit.a audit-libs-devel-1.5.3-1.fc7
/usr/lib/libauparse.a audit-libs-devel-1.5.3-1.fc7
/usr/lib/libbind.a bind-devel-9.4.1-6.1.fc7
/usr/lib/libbind9.a bind-devel-9.4.1-6.1.fc7
/usr/lib/libbluetooth.a bluez-libs-devel-3.9-1.fc7
/usr/lib/libbz2.a bzip2-devel-1.0.4-10.fc7
/usr/lib/libcrypto.a openssl-devel-0.9.8b-12.fc7
/usr/lib/libdns.a bind-devel-9.4.1-6.1.fc7
/usr/lib/libecpg.a postgresql-devel-8.2.4-1.fc7
/usr/lib/libecpg_compat.a postgresql-devel-8.2.4-1.fc7
/usr/lib/libelf.a elfutils-libelf-devel-static-0.128-2.fc7
/usr/lib/libexslt.a libxslt-devel-1.1.21-1.fc7
/usr/lib/libfl.a flex-2.5.33-9.fc7
/usr/lib/libgd.a gd-devel-2.0.34-2.fc7
/usr/lib/libgdbm.a gdbm-devel-1.8.0-27.fc7
/usr/lib/libgnutls-extra.a gnutls-devel-1.4.5-2.fc7
/usr/lib/libgnutls-openssl.a gnutls-devel-1.4.5-2.fc7
/usr/lib/libgnutls.a gnutls-devel-1.4.5-2.fc7
/usr/lib/libisc.a bind-devel-9.4.1-6.1.fc7
/usr/lib/libisccc.a bind-devel-9.4.1-6.1.fc7
/usr/lib/libisccfg.a bind-devel-9.4.1-6.1.fc7
/usr/lib/libkpathsea.a tetex-fonts-3.0-39.fc7
/usr/lib/libl.a flex-2.5.33-9.fc7
/usr/lib/liblockdev.a lockdev-devel-1.0.1-11.fc7
/usr/lib/liblwres.a bind-devel-9.4.1-6.1.fc7
/usr/lib/libmikmod.a mikmod-devel-3.2.2-2.fc7
/usr/lib/libname-server-2.a ORBit2-devel-2.14.7-3.fc7
/usr/lib/libnet.a libnet-devel-1.1.2.1-10.fc7
/usr/lib/libpci.a pciutils-devel-2.2.4-3.fc7
/usr/lib/libpgport.a postgresql-devel-8.2.4-1.fc7
/usr/lib/libpgtypes.a postgresql-devel-8.2.4-1.fc7
/usr/lib/libpopt.a popt-1.10.2-46.fc7
/usr/lib/libpq.a postgresql-devel-8.2.4-1.fc7
/usr/lib/librpm.a rpm-devel-4.4.2-46.fc7
/usr/lib/librpmbuild.a rpm-devel-4.4.2-46.fc7
/usr/lib/librpmdb.a rpm-devel-4.4.2-46.fc7
/usr/lib/librpmio.a rpm-devel-4.4.2-46.fc7
/usr/lib/libselinux.a libselinux-devel-2.0.14-4.fc7
/usr/lib/libsepol.a libsepol-devel-2.0.3-1.fc7
/usr/lib/libssl.a openssl-devel-0.9.8b-12.fc7
/usr/lib/libxml2.a libxml2-devel-2.6.29-1.fc7
/usr/lib/libxslt.a libxslt-devel-1.1.21-1.fc7
/usr/lib/libz.a zlib-devel-1.2.3-10.fc7
[root@vel tmp]#      
Comment 3 Miroslav Lichvar 2007-07-19 08:31:11 EDT
Well, this topic was thoroughly discussed on fedora-devel list. 

Please search the archives for "static linking" or have a look at:
http://people.redhat.com/drepper/no_static_linking.html
Comment 4 Robert Scheck 2010-04-05 21:20:26 EDT
Just for completeness: Package ssldump is part of Fedora 11+ and EPEL 4/5.
Comment 5 Eduard Vopicka 2010-04-06 07:21:21 EDT
If I remember well, the last time i have checked Fedora source rpm, some patches, considered by me as "must have" were missing. Please take a look at (for example)

http://download.opensuse.org/source/distribution/11.2/repo/oss/suse/src/ssldump-0.9b3-233.1.src.rpm

Brgds,

Ed
Comment 6 Robert Scheck 2010-04-06 07:56:45 EDT
Eduard, if something is missing in the Fedora ssldump source RPM, please open
bug reports and tell exactly what is missing or wrong. I won't check a foreign
source RPM just because somebody mentions differences.
Comment 7 Eduard Vopicka 2010-04-08 08:03:30 EDT
Robert: OK, I will do so, probably during the next weekend. I am so busy just now.

IMHO the main thing added by patches packaged in Suse source rpm is support for more ciphers. I have two or three patch sources for ssldump, so I will try to summarize.

Brgds,

Ed
Comment 8 Eduard Vopicka 2010-04-23 04:13:47 EDT
Robert:

now that ssldump-0.9-0.2.b3.fc12.i686 is out in F12 updates, I am happy to see that you did not resist sooner than I managed my time to allow me to look at it:

* Tue Apr 06 2010 Robert Scheck <robert@fedoraproject.org> 0.9-0.2.b3
- Added a patch to support AES cipher-suites (#248813 #c5)
- Added backporting patch from CVS 2006-06-19 (#248813 #c5)

I can only say thank you, that's it! And this means that I have just switched back to standard F12 ssldump as I have no longer reason to build my own openssl rpm.

Brgds,

Ed.
Comment 9 Eduard Vopicka 2010-04-23 04:19:29 EDT
s/openssl/ssldump/

Note You need to log in before you can comment on or make changes to this bug.