Bug 248831 - Round brackets are stripped out of the kickstart profile packages text box
Round brackets are stripped out of the kickstart profile packages text box
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
500
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2007-07-18 21:12 EDT by Trung Nguyen
Modified: 2009-09-10 15:21 EDT (History)
5 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:21:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart file. (14.96 KB, text/plain)
2007-07-18 21:12 EDT, Trung Nguyen
no flags Details

  None (edit)
Description Trung Nguyen 2007-07-18 21:12:52 EDT
Description of problem:
Round brackets are stripped out of the kickstart profile packages text box, 
eg "@KDE (K Desktop Environment)" be comes "@KDE K Desktop Environment" during 
the installion, as the result the package failed to install due to invalid 
package name.

Please note that this problem does not occur in Satellite 4.2.1

Version-Release number of selected component (if applicable):
Satellite 5.0.0

How reproducible:
List the package in the software section of the Kickstart "@KDE (K Desktop 
Environment)" 

Steps to Reproduce:
1.Insert the line "@KDE (K Desktop Environment)" into the packages text box in 
the software tab in the Kickstart profile
2.click "update packages"

  
Actual results:
Round brackets are stripped off.

Expected results:
group name should not be modified.

Additional info:
Please note that this problem does not occur in Satellite 4.2.1

Specifing the short group name "@kde-desktop" does not help and produce the 
same error - there may be other related bugs in anaconda/kickstart
Comment 1 Trung Nguyen 2007-07-18 21:12:52 EDT
Created attachment 159572 [details]
Kickstart file.
Comment 2 Mike McCune 2009-03-31 12:51:24 EDT
Just need to make sure that page isn't using the:

com.redhat.rhn.frontend.struts.ScrubbingDynaActionForm
Comment 3 Justin Sherrill 2009-04-03 16:52:51 EDT
seems to be working just fine now -> modified.
Comment 4 Steve Salevan 2009-04-17 13:06:57 EDT
This appears to be functioning on the 4/14 530 ISO.  Moving to VERIFIED.
Comment 5 Preethi Thomas 2009-07-29 13:41:22 EDT
release pending
stage 7/24 build. https://sun-x4200-01.rhts.bos.redhat.com

from the kickstart file

%packages 

@ Base
@KDE (K Desktop Environment)

%pre
Comment 6 Brandon Perkins 2009-09-10 15:21:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.