Bug 248831 - Round brackets are stripped out of the kickstart profile packages text box
Summary: Round brackets are stripped out of the kickstart profile packages text box
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer
Version: 500
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Steve Salevan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 457075
TreeView+ depends on / blocked
 
Reported: 2007-07-19 01:12 UTC by Trung Nguyen
Modified: 2009-09-10 19:21 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-09-10 19:21:14 UTC


Attachments (Terms of Use)
Kickstart file. (14.96 KB, text/plain)
2007-07-19 01:12 UTC, Trung Nguyen
no flags Details

Description Trung Nguyen 2007-07-19 01:12:52 UTC
Description of problem:
Round brackets are stripped out of the kickstart profile packages text box, 
eg "@KDE (K Desktop Environment)" be comes "@KDE K Desktop Environment" during 
the installion, as the result the package failed to install due to invalid 
package name.

Please note that this problem does not occur in Satellite 4.2.1

Version-Release number of selected component (if applicable):
Satellite 5.0.0

How reproducible:
List the package in the software section of the Kickstart "@KDE (K Desktop 
Environment)" 

Steps to Reproduce:
1.Insert the line "@KDE (K Desktop Environment)" into the packages text box in 
the software tab in the Kickstart profile
2.click "update packages"

  
Actual results:
Round brackets are stripped off.

Expected results:
group name should not be modified.

Additional info:
Please note that this problem does not occur in Satellite 4.2.1

Specifing the short group name "@kde-desktop" does not help and produce the 
same error - there may be other related bugs in anaconda/kickstart

Comment 1 Trung Nguyen 2007-07-19 01:12:52 UTC
Created attachment 159572 [details]
Kickstart file.

Comment 2 Mike McCune 2009-03-31 16:51:24 UTC
Just need to make sure that page isn't using the:

com.redhat.rhn.frontend.struts.ScrubbingDynaActionForm

Comment 3 Justin Sherrill 2009-04-03 20:52:51 UTC
seems to be working just fine now -> modified.

Comment 4 Steve Salevan 2009-04-17 17:06:57 UTC
This appears to be functioning on the 4/14 530 ISO.  Moving to VERIFIED.

Comment 5 Preethi Thomas 2009-07-29 17:41:22 UTC
release pending
stage 7/24 build. https://sun-x4200-01.rhts.bos.redhat.com

from the kickstart file

%packages 

@ Base
@KDE (K Desktop Environment)

%pre

Comment 6 Brandon Perkins 2009-09-10 19:21:14 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html


Note You need to log in before you can comment on or make changes to this bug.