Bug 248832 - Calendar will only add a one hour appointment today starting now
Calendar will only add a one hour appointment today starting now
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 21:18 EDT by P Jones
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 07:40:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Jones 2007-07-18 21:18:47 EDT
Description of problem: In version evolution-2.10.3-1.fc7, adding an appointment
to a calendar on any day at any time for any duration will only result in a one
hour appointment today starting now. Meaning, if I want to add a three hour
appointment starting at 7:00 AM two days ago, I click on July 16 in the mini
calendar, click on 7:00 AM in Day View and drag down to 10:00 AM, right click on
the selected area, select New Appointment, input some text, and then click Save,
the appointment will appear in Today (July 18) from 9:17 PM (the time right now)
to 10:17 PM.
Comment 1 Andre Klapper 2007-08-03 15:57:24 EDT
it does not work like this, but the other way round:
you first add an appointment for only one timeslot. after that, you can change
its length.
in my humble opinion this is not a bug, but it could be worth to file an
enhancement request upstream at bugzilla.gnome.org . however it could be hard to
fix this because double-clicking on the marked timeslots should bring up an
appointment editor with the marked time as default; while single-clicking would
still only mark a timeslot. tricky.
Comment 2 P Jones 2007-08-06 17:54:31 EDT
I've reverted back to the original F7 version of Evolution,
evolution-2.10.3-2.fc7. It behaves as expected; using the mouse to select a time
range on a day other than today will result in that date and time range being
passed to the New Appointment dialog.
Comment 3 P Jones 2007-08-06 17:59:44 EDT
Ooops, copied the wrong text. The original F7 version of Evolution is
evolution-2.10.1-4.fc7, not what I wrote in the last comment. My apologies...
Comment 4 Milan Crha 2007-11-21 07:40:50 EST
This is a feature, not a bug. There was other enhancement request upstream that
adding appointments in past has not much sense, so this was done to prevent
adding something what you cannot attend. There was done other enhancement to
make behavior more consistent, with respect to double clicking, right clicking
and using menu, so if I recall correctly, then double clicking and right
clicking will always use the day and time you've selected in calendar view and
other methods will protect you to add appointments in the past. You can check
that time in editor window is set to that which will be used. I'm not sure if
that enhancement has been taken to latest Fedora 7 evolution release, but is
definitely included in Fedora 8. Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.