Bug 248834 - kobject_add failed for brport, kernel BUG at net/core/net-sysfs.c
kobject_add failed for brport, kernel BUG at net/core/net-sysfs.c
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 23:08 EDT by Anssi Johansson
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.4-29.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-28 09:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog with the kernel error messages (43.03 KB, text/plain)
2007-07-18 23:08 EDT, Anssi Johansson
no flags Details
crash log (12.78 KB, text/plain)
2007-07-26 05:16 EDT, Felix Schwarz
no flags Details

  None (edit)
Description Anssi Johansson 2007-07-18 23:08:44 EDT
Description of problem:
Upgraded to kernel-xen-2.6.20-2925.13.fc7 (from updates-testing) and tried to
create a new Xen guest with virt-install. I got the following error message:

kernel BUG at net/core/net-sysfs.c:429!
invalid opcode: 0000 [1] SMP

The full syslog is attached, but here's the interesting part:

xen kernel: kobject_add failed for brport (-13)
xen kernel: Call Trace:
xen kernel:  [<ffffffff8031dce6>] kobject_add+0x163/0x18e
xen kernel:  [<ffffffff8823a493>] :bridge:br_add_if+0x1d2/0x2d8
xen kernel:  [<ffffffff8823ab7d>] :bridge:add_del_if+0x41/0x5e
xen kernel:  [<ffffffff8823b203>] :bridge:br_dev_ioctl+0x669/0x6a2

( with some SELinux errors, see bug 245274 comment 13 )

MySQL was running on the server when I got that error message, and it continued
running fine despite this error. However, I was no longer able to ssh into the
server. I tried rebooting the server remotely with 'shutdown -r now', but for
some unknown reason the server didn't shut down properly and I had to visit our
server room to power cycle the server. 

The previous version (2.6.20-2925.11) didn't crash like this.

This is on Dell Poweredge 2900, with two integrated NICs and a four port D-Link
DFE-580TX, which is hidden from Domain0 with
pciback.hide=(0c:04.0)(0c:05.0)(0c:06.0)(0c:07.0).

Version-Release number of selected component (if applicable):
bridge-utils-1.1-2
kernel-xen-2.6.20-2925.13.fc7
selinux-policy-targeted-2.6.4-28.fc7
selinux-policy-2.6.4-28.fc7

How reproducible:
Haven't tried to reproduce the problem yet

Steps to Reproduce:
1. boot with kernel-xen-2.6.20-2925.13
2. run virt-install to create a new guest image:
[root@xen ~]# virt-install
Would you like a fully virtualized guest (yes or no)?  This will allow you to
run unmodified operating systems. no
 What is the name of your virtual machine? gw
 How much RAM should be allocated (in megabytes)? 384
 What would you like to use as the disk (path)? /var/lib/xen/images/gw
 Would you like to enable graphics support? (yes or no) no
 What is the install location? ftp://192.168.0.160/documents/fc7/x86_64/os/
3. Crash!
  
Actual results:
Kernel crash

Expected results:
New Xen virtual machine created successfully
Comment 1 Anssi Johansson 2007-07-18 23:08:44 EDT
Created attachment 159574 [details]
syslog with the kernel error messages
Comment 2 Red Hat Bugzilla 2007-07-24 21:43:15 EDT
change QA contact
Comment 3 Felix Schwarz 2007-07-26 05:13:01 EDT
I see this bug, too (using 2.6.20-2925.11.fc7xen on x86_64). I can reproduce
this issue when doing 'xm create xenguest' which worked previously and stopped
working immediately after updating to selinux-policy-2.6.4-28.fc7 and
selinux-policy-targeted-2.6.4-28.fc7.

Before the SElinux update there was an SElinux denial, immediately afterwards I
got a "invalid opcode: 0000 [1] SMP" message on all consoles. Therefore I
suspect an SElinux issue and think the component should be changed to selinux.
Comment 4 Felix Schwarz 2007-07-26 05:16:18 EDT
Created attachment 159998 [details]
crash log

Attached you find call trace messages from Linux.
Comment 5 Anssi Johansson 2007-07-27 22:30:15 EDT
selinux-policy-targeted-2.6.4-29.fc7 doesn't seem to exhibit this problem any more.
Comment 6 Eduardo Habkost 2007-07-27 22:33:44 EDT
(In reply to comment #5)
> selinux-policy-targeted-2.6.4-29.fc7 doesn't seem to exhibit this problem 
any more.

Good. Should I close this bug?
Comment 7 Felix Schwarz 2007-07-28 05:37:59 EDT
selinux-policy-targeted-2.6.4-29.fc7 fixes the problem for me too so I think
this bug can be closed.

The only thing I noticed is that the changelog entry in the -29 rpm for the
latest revision is empty.
Comment 8 Eduardo Habkost 2007-07-28 09:17:59 EDT
Closing the bug. Changing component just to keep it recorded on the right 
component on bugzilla.

Note You need to log in before you can comment on or make changes to this bug.