Bug 248841 - HELP!!! Window manager disappeared!!!!
HELP!!! Window manager disappeared!!!!
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-07-19 01:26 EDT by The Source
Modified: 2008-06-16 21:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 21:54:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description The Source 2007-07-19 01:26:00 EDT
Description of problem:
When I started my system today all windows have no frame!!! And when I tried 
to launch window configuration program from main menu it said the window 
manager "unknown" has not registered settigs program. What hapenned?? How to 
fix it????

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 The Source 2007-07-19 07:36:00 EDT
I launched metacity manually from KDE and problem appeared. All new windows are
created without frame and title.
Comment 2 The Source 2007-07-20 02:31:40 EDT
Hmmm.. looks like metacity don't launch at startup at all (or perhaps crashes at
startup?). When in gnome I launched metacity manually windows returned to normal
state. I added metacity to startup in session configuration, but it is temporary
solution of course.
Comment 3 Ray Strode [halfline] 2007-07-22 18:55:32 EDT

Do you have desktop-effects installed?  If so, if you run it, is the "Enable
Desktop Effects" toggle button pushed in?

What is the output of

gconftool-2 -R /apps/gnome-session/rh/window_manager
gconftool-2 -R /desktop/gnome/applications/window_manager

Comment 4 The Source 2007-07-23 01:21:22 EDT
I have desktop-effects installed but button is not pressed. If I press it
however bug returns.

The first output is empty. The second one is here:

workspace_names = (значение не установлено)
 current = (значение не установлено)
 default = (значение не установлено)
 number_of_workspaces = (значение не установлено)

Phrase in brackets means that value is not set.
Comment 5 Ray Strode [halfline] 2007-07-23 13:47:45 EDT
So just to be clear, when you start off, you have window frames because of your
workaround.  If you run desktop-effects then the button is popped up (not
enabled).  If you click the button then the problem happens (so that it is
enabled) then the problem happens.  Right?

What if you click it again (so that it's not enabled), does it fix itself again?
Comment 6 The Source 2007-07-23 23:33:06 EDT
1. When I start, windows have frames only because I added "metacity
--sm-disable" to gnome session startup. Before that they hadn't any frames
(started to happen after some update, but I can't remember which one).
2. Yes, the problem appears after I enable button for desktop-effects and
disappears after I disable it.
3. The strangest thing is that this happens only on one of my two machines. They
have the same versions of all software.
Comment 7 Ray Strode [halfline] 2007-07-24 09:40:23 EDT
if you enable desktop effects (to trigger the problem) and then press alt-f2 and
type gtk-window-decorator and press enter, does the problem go away?
Comment 8 The Source 2007-07-24 10:00:46 EDT
Now I'm angry.
1. Keyboard shortcuts do not work while problem presents.
2. I was able to launch gtk-window-decorator from opened terminal and it
returned window frames.
3. But now I can't toggle desktop-effects at all because attempt to do this
causes system hang (only cursor is alive, can't switch to other console or
reboot, had to press reset). I was forced to add metacity to startup on my home
machine now because I can't disable desktop effects. Tried several times. Thanks
a lot for endangering my file systems.
Comment 9 Ray Strode [halfline] 2007-07-24 10:22:18 EDT

This sounds like you're having some odd compiz issues.  I'm going to reassign
this to compiz.

If it locks up again where you can only move the mouse, try pressing 


This will bring you to a text login screen.  From there you can login (as the
same user) and if you run:

export DISPLAY=:0
metacity --replace

It may recover your session.
Comment 10 The Source 2007-07-24 10:46:54 EDT
I already told that I can't switch to another console. I can't switch, I can't
kill Xorg (ctrl+alt+backspace), I can't reboot (ctrl+alt+del). Only reset works.
Comment 11 The Source 2007-07-25 12:46:41 EDT
Sometimes hang happens when restoring window from minimized state. Not every
window however. So far I was able to reproduce it with eMule. Image gets wacky
and cpu is severely used. Input does not work. Only reset helps.
Comment 12 The Source 2007-07-27 06:21:27 EDT
I don't know if it is the same bug or not, but Xorg hangs sometimes when eMule
(under wine) window is restored from minimized state. Happens every ~10-20
restorations. Image gets wacky, cpu is severely used, input does not work. Have
to press reset.
Comment 13 Samuel Sieb 2007-08-02 23:41:56 EDT
I'm seeing this too.  It seems to be related somehow to compiz.  But it happens
even when desktop effects are not enabled.  I used to be able to fix it by
enabling then disabling desktop effects, but now enabling it locks up X.  I can
fix it until the next time it happens by running metacity in a terminal.  When I
logout and log back in, it's still working.
I ran both those commands, the first gives no output, the second one gives:
 workspace_names = (no value set)
 current = (no value set)
 default = (no value set)
 number_of_workspaces = (no value set)
Comment 14 Samuel Sieb 2008-01-20 02:00:48 EST
On a clean F8 install, I ran into this problem again.  I had desktop effects
enabled and using fast user switching caused the window manager to die and not
come back.  I had to manually run the window manager in a console to get back.
Comment 15 Bug Zapper 2008-05-14 09:35:56 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Bug Zapper 2008-06-16 21:54:54 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.