Bug 248845 - An unhandled exception during installation on x86_64
Summary: An unhandled exception during installation on x86_64
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 4.0
Hardware: x86_64
OS: Linux
medium
urgent
Target Milestone: ---
: ---
Assignee: David Lehman
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-19 06:44 UTC by Ahmad Hussein
Modified: 2008-02-28 19:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 19:45:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump file (800.94 KB, text/plain)
2007-07-19 06:44 UTC, Ahmad Hussein
no flags Details

Description Ahmad Hussein 2007-07-19 06:44:41 UTC
Description of problem:
An unhandled exception during installation on x86_64

Traceback (most recent call last):
  File "/usr/src/build/711710-x86_64/install//usr/lib/anaconda/gui.py", line
1074, in handleRenderCallback
    self.currentWindow.renderCallback()
  File
"/usr/src/build/711710-x86_64/install//usr/lib/anaconda/iw/progress_gui.py",
line 242, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/src/build/711710-x86_64/install//usr/lib/anaconda/gui.py", line
789, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/src/build/711710-x86_64/install//usr/lib/anaconda/dispatch.py",
line 171, in gotoNext
    self.moveStep()
  File "/usr/src/build/711710-x86_64/install//usr/lib/anaconda/dispatch.py",
line 239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/src/build/711710-x86_64/install//usr/lib/anaconda/packages.py",
line 967, in doInstall
    syslog.start (instPath, syslogname)
  File "/usr/src/build/711710-x86_64/install//usr/lib/anaconda/syslogd.py", line
65, in start
    self.pid = os.fork ()
OSError: [Errno 12] Cannot allocate memory

Version-Release number of selected component (if applicable):RHEL WS 4 Update 3


How reproducible:
Constantly encoutering error. Could not proceed with any installation

Steps to Reproduce:
1. Hardware: HP Workstation xw8200 4GB memory, 4 x 73GB SCSI Drives, Nvidia
Quadro NVS 285, 2 x HP1955 LCD Display

2. Boot machine from the RHEL-WS_4 CD No. 1

3. Installation crashed soon after disk formatting ends and transfering of src
image.   
  
Actual results:


Expected results:


Additional info:

Comment 1 Ahmad Hussein 2007-07-19 06:44:41 UTC
Created attachment 159579 [details]
anaconda dump file

Comment 4 Denise Dumas 2008-02-28 19:28:43 UTC
This problem was reported on RHEL WS 4 Update 3, and we believe it has been
corrected since then. Certainly x86_64 installation succeeds. We're already
stretching Anaconda capacity to the limits for this release, so I'm dev-NAKing
this. 

Comment 5 RHEL Product and Program Management 2008-02-28 19:45:57 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 


Note You need to log in before you can comment on or make changes to this bug.