This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 248879 - tpb eating CPU (> 25% Xorg)
tpb eating CPU (> 25% Xorg)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tpb (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-19 08:45 EDT by Stephen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 16:44:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen 2007-07-19 08:45:26 EDT
My Z60t ThinkPad 'idling':

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
                                         
 2128 root      15   0 36516 2444 1356 S 12.0  0.2 138:15.30 NetworkManager    
                                         
 2597 sd        15   0  598m 311m  73m R  0.7 31.1 256:16.31 firefox-bin       
                                         
 2224 root      15   0  579m 181m 9216 R  0.3 18.1  48:07.32 Xorg              
                                         
 2332 sd        15   0 15576 1264 1000 S  0.3  0.1  13:52.50 tpb

tpb is using more than 25% as much CPU as Xorg (and I'm not mashing on the
volume buttons!).  uptime above: 2 days.

I don't recall seeing tpb that high before, but I haven't been looking since I
upgraded from FC6 so I can't be sure when this started happening.

kernel-2.6.21-1.3228.fc7
tpb-0.6.4-8.fc7
Comment 1 Kevin Fenzi 2007-07-30 11:27:37 EDT
(Sorry for the delay here, I was out of town...)

quite odd. 

What arch is your install? i686? or x86_64?

Can you see if the latest update kernel fixes the issue?
Comment 2 Stephen 2007-08-21 09:15:08 EDT
Arch is i686.  I've updated to kernel-2.6.22.1-41.fc7 (and all other updates)
and the problem is still there.

I also tried lowering POLLTIME in /etc/tpbrc from the default 200000 to 400000
but it didn't seem to make much difference to the CPU consumption, although the
volume buttons often failed to work... :-)


Is there a way to get rid of tpb altogether? I thought I read on planet Gnome
(Richard Hughes?) that the thinkpad extra buttons were supported as ACPI events.
What listens for these events? Is there a package I can install, so that the
polling tpb can be dropped?
Comment 3 Kevin Fenzi 2007-08-21 17:02:58 EDT
Perhaps you mean this post: http://hughsient.livejournal.com/29730.html
If you can bypass tpb that would be a great solution. 

tpb seems pretty much dead upstream. ;( 
Comment 4 Stephen 2007-08-22 14:10:48 EDT
Yeah, that's the one.

So, looks like tpb is dead but HAL will handle this in F8. Groovy.

I guess this bug can be closed?


Thanks for looking!
Comment 5 Kevin Fenzi 2007-08-22 15:28:40 EDT
Sure, I'd be happy to close this... Do you have any way to test and see if you
can get things working with the new setup? I hate to close this without being
sure that it will get solved for you. 

Possibly booting the f8test1 live image? 
Comment 6 Kevin Fenzi 2007-10-15 16:44:29 EDT
I'll go ahead and close this now. 
Feel free to reopen or file a new bug if you see it again... 

Note You need to log in before you can comment on or make changes to this bug.