This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 24888 - BIND 9 not serving up local information
BIND 9 not serving up local information
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-24 17:41 EST by Wade Minter
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 17:41:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Wade Minter 2001-01-24 17:41:27 EST
I'm not sure if I'm doing something wrong or bind is acting weird, but
bind-9.1.0-0.b2.1 in beta2 isn't returning information on my local
domains.  I've got this in my named.conf file:

zone "lunenburg.org"{
        type master;
        file "db.lunenburg.org";
};

And the file db.lunenburg.org has proper zone information (copied from a
working bind8 server).  But when I query bind for information in the
lunenburg.org zone, it spits back something like:

> server 192.168.0.1
Default server: 192.168.0.1
Address: 192.168.0.1#53
> dundas.lunenburg.org
Server:         192.168.0.1
Address:        192.168.0.1#53

** server can't find dundas.lunenburg.org.: SERVFAIL
>

The db.lunenburg.org file looks like:

@ IN SOA        courthouse.lunenburg.org.        minter.lunenburg.org.
        (
                2000091501;     Serial
                10800;          Refresh after 3 hours
                3600;           Retry after 1 hour
                604800;         Expire after 1 week
                86400 );        Minimum TTL of 1 day

                IN NS   courthouse.lunenburg.org.

www             IN A            216.235.79.243
mail            IN CNAME        www.lunenburg.org.
courthouse      IN A            192.168.0.1
kenbridge       IN A            192.168.0.2
victoria        IN A            192.168.0.3
dundas          IN A            192.168.0.4

/var/log/messages only says:

Jan 24 17:48:19 courthouse named[1692]: dns_master_load:
db.lunenburg.org:1: no TTL specified
Jan 24 17:48:19 courthouse named[1692]: dns_zone_load: zone
lunenburg.org/IN: loading master file db.lunenburg.org: no ttl
Comment 1 Bernhard Rosenkraenzer 2001-01-24 17:53:47 EST
Your zone file is not RFC compliant. Prior versions warned you about this, the
current version doesn't accept the file.
It`s just what syslog says: no TTL specified.

The easiest way to specify a TTL is adding it right after the "@" in the first
line, e.g.

@ 3600000 IN SOA courthouse.lunenburg.org. minter.lunenburg.org.

Note You need to log in before you can comment on or make changes to this bug.