Bug 248881 - NetworkManager eating CPU
Summary: NetworkManager eating CPU
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-19 13:11 UTC by Stephen
Modified: 2008-05-01 10:35 UTC (History)
0 users

Fixed In Version: 0.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-01 10:35:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen 2007-07-19 13:11:12 UTC
Periodically NetworkManager seems to hog the CPU for minutes at a time. Snapshot:

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
                                         
 2128 root      15   0 36516 2444 1356 S 12.0  0.2 138:15.30 NetworkManager    
                                         
 2597 sd        15   0  598m 311m  73m R  0.7 31.1 256:16.31 firefox-bin       
                                         
 2224 root      15   0  579m 181m 9216 R  0.3 18.1  48:07.32 Xorg              
                                         
 2332 sd        15   0 15576 1264 1000 S  0.3  0.1  13:52.50 tpb

As I write this, it's gone quiet again. But as you can see from above it adds up
over time. (uptime 2days above)

It doesn't seem related to network activity or dropouts or changing network.

This is a new problem (since I upgraded from FC6? Can't be sure, but seems recent)

This machine has an atheros chipset. I'm using the madwifi driver from livna:

kernel-2.6.21-1.3228.fc7
kmod-madwifi-0.9.3.1-1.2.6.21_1.3228.fc7.i686.rpm
madwifi-0.9.3.1-1.lvn7.i386.rpm
NetworkManager-0.6.5-7.fc7

Comment 1 Dan Williams 2008-04-22 18:40:37 UTC
Does this still happen with NM 0.6.6 which is available from F7 updates?

Comment 2 Stephen 2008-04-30 14:50:14 UTC
Don't know about F7 (no box to test), but it doesn't happen with F8.

Comment 3 Dan Williams 2008-05-01 10:35:57 UTC
ok, thanks!


Note You need to log in before you can comment on or make changes to this bug.