Bug 248930 - wish: add install DVD repository
Summary: wish: add install DVD repository
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-19 17:31 UTC by Nadav Kavalerchik
Modified: 2014-01-21 22:59 UTC (History)
4 users (show)

Fixed In Version: f8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 18:39:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Yum crash dump (686 bytes, text/plain)
2007-07-30 12:36 UTC, Philip Ashmore
no flags Details
A patch to the yum module (396 bytes, text/x-patch)
2007-07-30 12:42 UTC, Philip Ashmore
no flags Details
allow spaces in yum baseurl (734 bytes, patch)
2007-12-03 18:14 UTC, Henry Kroll
no flags Details | Diff

Description Nadav Kavalerchik 2007-07-19 17:31:46 UTC
Description of problem:

after installing a new fc7 i wanted to add a package or a group of packages from
the install DVDs. but there was no way to do so (maybe i just didn't know how!)

i read on the net that some one suggested to mount the DVD and add a repo file
in /etc/yum.repo.d/DVD.repo so yum could recognize it.
so i did and only then i could use the install DVD with yum or pup
but then i got an error trying to actually install one of the package groups.
(never mind the error)

anyways, i think there should be an easy way (for people how don't know how to
add .repo files) to install packages after the first install, especially, if
there is no link to the internet.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Andre Robatino 2007-07-19 18:51:03 UTC
  It would really be nice if this could be integrated with yum-presto so one
could have the option of combining an old package on DVD with a downloaded
deltarpm to minimize downloading.

Comment 2 Philip Ashmore 2007-07-30 12:36:59 UTC
Created attachment 160240 [details]
Yum crash dump

Comment 3 Seth Vidal 2007-07-30 12:40:35 UTC
The crash dump is an error that's been  fixed in a later yum release.

yum 3.2.2 is in updates-testing, please upgrade to that and try the conditions
that created the error.

thanks


Comment 4 Philip Ashmore 2007-07-30 12:42:00 UTC
Created attachment 160241 [details]
A patch to the yum module

As ROOT
cd /usr/lib/python2.5/site-packages/
patch -p0 < {location of patch}/yum-packages.py.patch

Comment 5 Philip Ashmore 2007-07-30 12:56:33 UTC
I had a similar (if not the same) problem recently - the crash dump is attached.
I created a patch (also attached) that allows yum to ignore the fact that the
repo now has no media number - I don't fully understand it myself but at least
it now works.

Comment 6 Philip Ashmore 2007-07-30 13:02:50 UTC
Oops! I just witnessed the mid-air collision in bug updates. Sorry for any toe
stepping.
I tried the yum in updates-testing and It worked with my local DVD repo.
In case it doesn't fix the problem for you I've submitted my patch anyway for
review.
I would still like to know why yum is looking for a media number given that the
repo is on a local disk (not on media) but I suspect that this is because of a
file contained within the repo itself, or am I asking the wrong question?
I remember having this problem before when some KDE components (?) weren't
installed, preventing yum from decoding media:// urls.

Comment 7 Philip Ashmore 2007-07-30 13:36:53 UTC
The media:// problem I mentioned happened with FC3 or FC5

Comment 8 Henry Kroll 2007-12-03 18:14:19 UTC
Created attachment 275951 [details]
allow spaces in yum baseurl

Comment 9 Henry Kroll 2007-12-03 18:18:14 UTC
There is a (bug?) in Fedora 8 where if you let Gnome auto-mount the DVD (most
users will) it will mount it as "/media/Fedora 8 i386 DVD" and if you put
file:///media/Fedora 8 i386 DVD in your dvd.repo it will give you an error:
 
Options Error: Error parsing 'file:///media/Fedora 8 i386 DVD': URL must be
http, ftp, file or https not ""

This happens because there are spaces in the name of the CD, which is the name
that K3B gives it when you burn the ISO. The workaround is to either give your
DVD a name with no spaces in it or apply a patch similar to the above patch to
config.py

Comment 10 Jeremy Katz 2007-12-03 18:39:24 UTC
That's not really the way you want to set up the DVD repo.  You really want to
use the mediaid support so that you can properly be prompted for the DVD if you
don't already have it inserted.

If you install Fedora 8 from DVD, this gets set up automatically.  If you don't
and want to add it later, just copy the repo file from the top-level of the DVD
and things will work properly.


Note You need to log in before you can comment on or make changes to this bug.