Bug 248932 - kernel panics -- not sure why
kernel panics -- not sure why
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-19 13:59 EDT by Matěj Cepl
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 14:35:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (5.28 MB, text/plain)
2007-07-19 13:59 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2007-07-19 13:59:11 EDT
Description of problem:
sometimes kernel panics. I use ndiswrapper (I have to, my BCM4318 is not
supported even in the latest kernels by John Linville) and now in Guadec when I
was switching often networks, I got couple of kernel panics.

Version-Release number of selected component (if applicable):
both
kernel-2.6.22.1-20.fc7
kernel-2.6.22.1-27.fc7 (the latter seems to be worse)

How reproducible:
from time to time (like twice a day)

Steps to Reproduce:
1.use computer, with connection failing anytime (because of overloaded
infrastructure), many times switch different networks, etc.
2.
3.
  
Actual results:
computer freezes, with ScrollLock and CapsLocks flashing

Expected results:
everything works fine and the world gets to the peace and harmony

Additional info:
I am not quite sure for what to look in the /var/log/messages so I am attaching
whole thing. Anything more? (this is the first time I am filing bug about kernel
panics, so not sure what's required).
Comment 1 Matěj Cepl 2007-07-19 13:59:13 EDT
Created attachment 159598 [details]
/var/log/messages
Comment 2 Chuck Ebbert 2007-07-19 14:35:09 EDT
ndiswrapper will cause problems on fedora kernels.

http://www.linuxant.com/driverloader/wlan/limitations.php

The only known fix is to use the linuxant 16k stack kernels.

Comment 3 Matěj Cepl 2007-07-20 05:41:23 EDT
I can understand that you don't want to get a dirty with binary-only stuff
(being desktop team bugmaster I close nvidia/ati bugs every day), however this
is a regression -- ndiswrapper works like a charm with 2.6.21 and previous
kernels, but not with 2.6.22.

Note You need to log in before you can comment on or make changes to this bug.