Bug 248940 - netpbm-progs: pstopnm requires ghostscript, but it's not listed as a dependancy of netpbm-progs
netpbm-progs: pstopnm requires ghostscript, but it's not listed as a dependan...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-19 14:23 EDT by Greg Swallow
Modified: 2013-07-02 19:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 04:53:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Swallow 2007-07-19 14:23:31 EDT
Description of problem:
netpbm-progs should require ghostscript - it doesn't

Version-Release number of selected component (if applicable):
netpbm-progs-10.35-14.fc8

How reproducible:
n/a

Steps to Reproduce:
1.Install netpbm-progs without ghostscript installed
2.do anything with /usr/bin/pstopnm
3.error to the effect of "can't find /usr/bin/gs"
  
Additional info:
http://netpbm.sourceforge.net/doc/pstopnm.html
"If you don't have GhostScript installed or the version you have installed was 
not built with the relevant PNM device drivers, pstopnm will fail."

Unfortunatly installing ghostscript (for me at least) brings in quite a few 
dependancies that I didn't have installed before, but oh well - I need pstopnm 
to work)

Thanks
Comment 1 Jindrich Novy 2007-07-25 04:53:14 EDT
Unfortunately I cannot add a hard dependency to ghostscript in netpbm-progs,
because only two programs out of the total 317 shipped within netpbm-progs
require ghostscript (pstopnm and pbmtextps) to handle postscript files so that
it would cause unneeded dependency bloat. It is common practise to not to add
such dependencies as RPM doesn't support "suggest" dependencies and let the
users install them when needed.

Sorry, it's not a good solution, but if you need pstopnm and pbmtextps to work,
use yum to install ghostscript separately.

Note You need to log in before you can comment on or make changes to this bug.