Bug 248961 - Autofs does not gracefully handle the MTAB_NOTUPDATED exit code from [u]mount
Autofs does not gracefully handle the MTAB_NOTUPDATED exit code from [u]mount
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs (Show other bugs)
4.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-19 16:49 EDT by Jeffrey Moyer
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0734
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:02:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gracefully handle the mtab notupdated exit code from mount/umount. (10.46 KB, patch)
2007-07-19 16:49 EDT, Jeffrey Moyer
no flags Details | Diff

  None (edit)
Description Jeffrey Moyer 2007-07-19 16:49:37 EDT
Description of problem:
Autofs will fail to start if mount is unable to update the mtab file.  It will
also fail to mount indirect mount points because of this problem.

I ran into this problem while running our regression test suite against autofs
v4.  Specifically, test /CoreOS/autofs/bugzillas/ subtest bz23829 failed.

Version-Release number of selected component (if applicable):
4.1.3-222

How reproducible:
100%

Steps to Reproduce:
Run the RHTS regression test described above.

Additional info:

The fix retries mounts that fail with MTAB_NOTUPDATED (return code 16),
specifying the -f option.  This tells mount to not actually perform a mount, but
to try to update /etc/mtab.  umount has no such option, so we simply retry the
umount.  The number of retries is set to 3 in both cases (and mount/umount have
builtin retry timeouts, as well).
Comment 1 Jeffrey Moyer 2007-07-19 16:49:37 EDT
Created attachment 159609 [details]
Gracefully handle the mtab notupdated exit code from mount/umount.
Comment 2 RHEL Product and Program Management 2007-07-19 16:55:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2007-11-15 11:02:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0734.html

Note You need to log in before you can comment on or make changes to this bug.