Bug 248973 - virt-manager serial console doesn't refresh during reboot
virt-manager serial console doesn't refresh during reboot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks: 409971
  Show dependency treegraph
 
Reported: 2007-07-19 18:20 EDT by Chuck Morrison
Modified: 2010-10-22 12:41 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:20:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Refresh serial console on domain reboot. (3.64 KB, application/octet-stream)
2008-09-18 13:58 EDT, Cole Robinson
no flags Details

  None (edit)
Description Chuck Morrison 2007-07-19 18:20:20 EDT
Description of problem:

When rebooting a (PV) domainU with the Virtual Machine Manager/Console while the
serial console component is open, The serial console does not follow the virtual
machine and stays at the old (defunct) vm. 

Version-Release number of selected component (if applicable):

rhel5.1 prebeta

How reproducible:

every time

Steps to Reproduce:
1. initiate a virtual machine manager session and start up a domU, with the
serial console (VM Console -> view -> serial console)
2. reboot the domU
3. As it reboots watch the serial console window. 
  
Actual results:

The serial console stays at the defunct session.

Expected results:

That the console would follow the domU through the reboot. 

Additional info:

It's possible to attach the serial console to the new session by (VM Console ->
view -> serial console) while or after the new boot.
Comment 1 Chuck Morrison 2007-08-08 12:04:37 EDT
This is still the case in beta 1.
Comment 2 Amy Griffis 2007-10-26 15:21:07 EDT
Still seen in rc2.
Comment 4 RHEL Product and Program Management 2008-06-02 16:35:33 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Cole Robinson 2008-09-18 12:16:49 EDT
Okay, I've reproduced this. I'll see if I can work up a fix.
Comment 8 Cole Robinson 2008-09-18 13:58:59 EDT
Created attachment 317103 [details]
Refresh serial console on domain reboot.

This is the upstream cset that (inadvertently?) fixed this issue.
Comment 9 Jay Turner 2008-09-19 10:43:06 EDT
QE ack for 5.3.
Comment 12 Peng ZhenFei 2008-12-12 03:18:48 EST
we can reproduced this issue on rhel5.3s5

serial console do not follow VM
Comment 13 Chris Ward 2008-12-12 03:28:29 EST
If i'm reading you right Peng, then this bug FAILS_QA. Please provide us with more details ASAP, as it's getting very late in the release cycle to do much else to get this fix in. We need to make a decision on what to do very quickly.
Comment 14 Peng ZhenFei 2008-12-12 04:54:10 EST
just follow the BUG Description  and we hit the bug .
we reboot the pv . graphical console will show the whole reboot process .
but serial console dont
Comment 16 Cole Robinson 2008-12-12 14:51:15 EST
Hmm, seems to work here:

# rpm -q kernel-xen xen virt-manager
kernel-xen-2.6.18-126.el5
xen-3.0.3-78.el5
virt-manager-0.5.3-10.el5

My steps:

1) Start a pre-existing rhel5 x86_64 PV guest
2) When VNC console opens, go to View->Serial Console
   Startup output starts flowing on the serial console.
3) When serial console reaches a login prompt, login, run 'reboot'
   Watch shutdown output scroll by, VM momentarilly stops, VNC window
   and serial console remain open the whole time.
4) VM starts up, start up output starts flowing on serial console.


I tried rebooting from inside the guest, use 'xm reboot', and using
'Shutdown' and 'Run' options from the virt-manager vnc window session,
and it all worked for me.

Does this look like what others are doing? Is anyone using non default preferences options in virt-manager?
Comment 18 Chuck Morrison 2008-12-12 18:14:14 EST
I filed the original bug over a year ago. rhel5.1 xen was considerably different from rhel5.3 xen. I don't recall if it was even possible to do a graphical install when the bug was filed. Much has changed. For one thing, it appears that current versions do not allow you to use the serial console as a working console, it only displays boot messages. Probably a moot point as virt-manager allows you to access virtual consoles independent of the serial console. If the serial console is intended to be a live shell, then that is a different issue.

Having just installed rhel5.3s5 and attempted to recreate the bug, I find that the serial console does in fact respond to a reboot and displays a booting system. I set this up with serial=ttyS0 and console=ttyS0 as boot options (separately) and the behavior is the same.

From my point of view the original bug has been addressed.
Comment 19 Chuck Morrison 2008-12-15 18:46:16 EST
Another install using rh5.3s5 and the serial console is quite usable. This is with console=ttyS0 as an append line in /boot/efi/efi/redhat/elilo.conf (ia64). So this issue appears to be fixed, as long as it makes it into a production release.

I now find that a reboot command in serial console, a virtual console in the virt-manager console or via the X interface merely shuts down the pv. I'll file a different report on that.
Comment 20 Bill Burns 2008-12-15 19:17:27 EST
Ok thanks, moving this bug back to on_qa then...
Comment 23 Chuck Morrison 2008-12-19 13:32:07 EST
I'm going to revise my "works for me" comment #19. This works sometimes and doesn't sometimes. I can find no rhyme or reason for it. If I reboot 10 times, it's likely to follow the boot 5 times and need to be re-viewed the other 5. 

So I'm changing this to Fails_QA.
Comment 27 errata-xmlrpc 2009-01-20 16:20:34 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0137.html

Note You need to log in before you can comment on or make changes to this bug.