Bug 248974 - DS opens wrong sasl plugins
DS opens wrong sasl plugins
Status: CLOSED WONTFIX
Product: 389
Classification: Community
Component: Database - General (Show other bugs)
1.0.4
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Orla Hegarty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-19 18:24 EDT by Karl MacMillan
Modified: 2007-07-20 16:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-20 16:45:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl MacMillan 2007-07-19 18:24:15 EDT
Description of problem:

The 64bit version of fedora-ds-base tries to open the 32bit sasl plugins while
the 32bit version opens the 64bit sasl plugins.

64bit fedora-ds-base output in /var/log/messages:

Jul 19 17:08:21 localhost ns-slapd: unable to dlopen
/usr/lib/sasl2/libsasldb.so.2: /usr/lib/sasl2/libsasldb.so.2: wrong ELF class:
ELFCLASS32
Jul 19 17:08:21 localhost ns-slapd: unable to dlopen
/usr/lib/sasl2/libanonymous.so.2: /usr/lib/sasl2/libanonymous.so.2: wrong ELF
class: ELFCLASS32


32bit fedora-ds-base output:

Jul 19 16:56:58 localhost ns-slapd: unable to dlopen
/usr/lib64/sasl2/liblogin.so.2: /usr/lib64/sasl2/liblogin.so.2: wrong ELF class:
ELFCLASS64
Jul 19 16:56:58 localhost ns-slapd: unable to dlopen
/usr/lib64/sasl2/libcrammd5.so.2: /usr/lib64/sasl2/libcrammd5.so.2: wrong ELF
class: ELFCLASS64
Jul 19 16:56:58 localhost ns-slapd: unable to dlopen
/usr/lib64/sasl2/libsasldb.so.2: /usr/lib64/sasl2/libsasldb.so.2: wrong ELF
class: ELFCLASS64
Jul 19 16:56:58 localhost ns-slapd: unable to dlopen
/usr/lib64/sasl2/libplain.so.2: /usr/lib64/sasl2/libplain.so.2: wrong ELF class:
ELFCLASS64
Jul 19 16:56:58 localhost ns-slapd: unable to dlopen
/usr/lib64/sasl2/libanonymous.so.2: /usr/lib64/sasl2/libanonymous.so.2: wrong
ELF class: ELFCLASS64


Version-Release number of selected component (if applicable):

Installed Packages
cyrus-sasl.x86_64                        2.1.22-6               installed       
cyrus-sasl-devel.x86_64                  2.1.22-6               installed       
cyrus-sasl-lib.x86_64                    2.1.22-6               installed       
cyrus-sasl-lib.i386                      2.1.22-6               installed       
cyrus-sasl-md5.x86_64                    2.1.22-6               installed       
cyrus-sasl-plain.x86_64                  2.1.22-6               installed 

How reproducible:

Always

Steps to Reproduce:
1. Install either 32 or 64bit fedora-ds-base
2. Create instance with ds_newinst.pl
3. Start with init script
Comment 1 Rich Megginson 2007-07-20 16:45:37 EDT
This is due to the bogus value for ServerRoot in the install.inf file.  For
i386, use 
ServerRoot = /usr/lib/fedora-ds
and for x86_64 use
ServerRoot = /usr/lib64/fedora-ds

I'm marking this as WONTFIX because the next version of Fedora DS will eliminate
ds_newinst.pl and install.inf

Note You need to log in before you can comment on or make changes to this bug.