Bug 248986 - Very slow screen redraw/repaint during basic usage
Very slow screen redraw/repaint during basic usage
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 01:38 EDT by Chris Langlands
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 03:27:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Langlands 2007-07-20 01:38:07 EDT
We recently updated from FC6 to F7 and the performance of Open Office has fallen
significantly.  All functions are good, but screen redraws when moving around
documents, or switching away and then back to an Open Office application, are
very slow.  

The screen redraws toolbar icon by toolbar icon.  

When using calc, scrolling around involves painful redraws of column data, and
then selections.  Sometimes in calc, selections are redrawn in an endless loop,
for a strobing effect, whilst there is no user interaction with calc.

System is an AMD Athlon64 X2 4200.  Video driver is Radeon.  

Is this something to do with Cairo?
Comment 1 Caolan McNamara 2007-07-20 04:38:49 EDT
It shouldn't be cairo, cairo is used for the full-screen presentation mode, but
otherwise the UI stuff is effectively unchanged from FC-6. I haven't had any
reports specifically like this before.

Is OOo the only application that behaves like this ? And is there anything
unusual about your setup that you are aware of ?
Comment 2 Caolan McNamara 2007-07-24 08:33:12 EDT
btw, what desktop environment KDE or GNOME. Any particular theme ?
Comment 3 Chris Langlands 2007-07-24 11:03:26 EDT
Thanks for following up.  Desktop is Gnome, using the default Gnome theme
(Clearlooks I think it's called).

But, the problem that I raised in this bug has gone away.  I don't have any idea
what resolved it.  Happy for you to close it.

Thank you.
Comment 4 Caolan McNamara 2007-07-24 11:13:13 EDT
It just stopped redrawing horribly slowing and became acceptable recently ?

Perhaps there was some background process which was beating the hell out of the
system.
Comment 5 Chris Langlands 2007-07-24 23:31:14 EDT
I don't use OpenOffice every day, so I cannot put my finger on when things
improved, but yes the redraw problem was present from at least 18-Jul to 21-Jul.

I did check load, I/O, etc and there was nothing unusual.  I also waited a few
days before filing the bug report.  I really don't know what was the cause. 
Maybe it was something in the xen testing kernel that I am using.

Sorry if I have wasted your time.  I will keep an eye on it, and add a comment
if I see the problem again.
Comment 6 Caolan McNamara 2007-07-25 03:27:15 EDT
Most odd. Indeed, keep an eye on it and if there is something that triggers this
again reopen and we'll make a stab at figuring it out.

Note You need to log in before you can comment on or make changes to this bug.