Bug 249058 - Init script for syslogd fails with complaint about permissions
Init script for syslogd fails with complaint about permissions
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: initscripts Maintenance Team
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 13:08 EDT by Paul Hughett
Modified: 2009-03-11 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-11 12:55:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Results of "strace /etc/rc.d/init.d/syslog start (24.79 KB, text/plain)
2007-08-14 15:17 EDT, Paul Hughett
no flags Details

  None (edit)
Description Paul Hughett 2007-07-20 13:08:17 EDT
Description of problem:

The init script to start syslogd fails during boot or on manual start up with
an error message

   Starting system logger: syslogd: error while loading shared libraries:    
   libc.so.6: cannot open shared object file: Permission denied


Version-Release number of selected component (if applicable):

initscripts-7.93.29.EL-1
glibc-2.3.4-2.36  for both i86 and x86-64 versions.


How reproducible:

Consistent failure with the above error message.

Steps to Reproduce:

1.  Type "sudo /etc/rc.d/init.d/syslog start"
  
Actual results:

Error message is output:

   Starting system logger: syslogd: error while loading shared libraries:    
   libc.so.6: cannot open shared object file: Permission denied


Expected results:

Init script starts the daemon and reports [  OK  ]


Additional info:

The permissions for /lib64/libc.so.6 and /lib64/libc-2.3.4.so are both 755.

Running 'sudo /sbin/syslogd -m 0' by hand starts up the syslogd daemon with no
apparent problems.
Comment 1 Bill Nottingham 2007-07-20 13:16:14 EDT
Something else is wrong with your system. What does a strace of syslogd startup
show?
Comment 2 Paul Hughett 2007-08-14 15:17:44 EDT
Created attachment 161299 [details]
Results of "strace /etc/rc.d/init.d/syslog start

This file shows the output from running the command

   strace /etc/rc.d/init.d/syslog start
Comment 3 Bill Nottingham 2007-08-29 13:08:54 EDT
Need a strace of the syslogd binary starting, not the init script.
Comment 4 Bill Nottingham 2009-03-11 12:55:42 EDT
Closing due to the lack of response.

Note You need to log in before you can comment on or make changes to this bug.