Bug 249080 - Build failure due to poppler build problems
Summary: Build failure due to poppler build problems
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby-gnome2 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Allisson Azevedo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-20 19:16 UTC by Jesse Keating
Modified: 2013-01-10 02:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 19:17:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesse Keating 2007-07-20 19:16:13 UTC
Rebuilds of ruby-gnome2 for new firefox error during building of poppler stuff:

gcc -I. -I/builddir/build/BUILD/ruby-gnome2-all-0.16.0/glib/src -I.
-I/usr/lib64/ruby/1.8/x86_64-linux -I.././poppler -DHAVE_RB_DEFINE_ALLOC_FUNC
-DHAVE_RB_BLOCK_PROC -DHAVE_OBJECT_ALLOCATE -DHAVE_NODE_ATTRASGN
-DHAVE_RB_CAIRO_H -DHAVE_POPPLER_PAGE_RENDER_SELECTION_TO_PIXBUF
-DRUBY_POPPLER_COMPILATION  -I/usr/lib64/ruby/site_ruby/1.8/x86_64-linux  -fPIC
-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -Wall  -fPIC -Wall
-I/usr/include/poppler/glib -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include
-I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include
-I/usr/include/pango-1.0   -I/usr/include/cairo    -c rbpoppler-page.c
rbpoppler-page.c: In function 'page_render_selection':
rbpoppler-page.c:149: error: incompatible type for argument 5 of
'poppler_page_render_selection'
rbpoppler-page.c:149: error: too few arguments to function
'poppler_page_render_selection'
rbpoppler-page.c: In function 'page_render_selection_to_pixbuf':
rbpoppler-page.c:174: error: incompatible type for argument 7 of
'poppler_page_render_selection_to_pixbuf'
rbpoppler-page.c:174: error: too few arguments to function
'poppler_page_render_selection_to_pixbuf'
make[2]: *** [rbpoppler-page.o] Error 1
make[2]: Leaving directory
`/builddir/build/BUILD/ruby-gnome2-all-0.16.0/poppler/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/ruby-gnome2-all-0.16.0/poppler'

For full build log see
http://koji.fedoraproject.org/koji/getfile?taskID=71910&name=build.log

Fedora 8 Test1 freeze is very soon, please correct this to fix the broken deps.

Comment 1 Allisson Azevedo 2007-08-03 16:55:10 UTC
Hi,

This is a strange error, maybe gcc bug, the same spec run in F-7 branch:
http://koji.fedoraproject.org/koji/taskinfo?taskID=87597 .



Comment 2 Jesse Keating 2007-08-03 16:58:17 UTC
Actually I think gcc is being more strict about coding language.  Please look at
the line it is complaining about and see if perhaps you have an open that is
malformed.

Comment 3 Mamoru TASAKA 2007-08-03 17:55:04 UTC
Well, I applied patches extracted from CVS.
This is due that ABI change occured at poppler 0.5.9.
Also gtk glib won't be rebuilt due to prototype mismatch.

Now I am rebuilding:
http://koji.fedoraproject.org/koji/taskinfo?taskID=88013
On x86_64 it succeeded. On the rest arch, it is now rebuilding
(perhaps they will succeed)

Comment 4 Mamoru TASAKA 2007-08-03 18:12:38 UTC
Rebuild succeeded on all arch, dist-f8.

Comment 5 Mamoru TASAKA 2007-08-03 18:15:32 UTC
(Note: my rebuild is scratch build, so the fixes I applied is
       not yet applied to Fedora CVS. I don't have right to
       access ruby-gnome2 Fedora CVS.

       Please apply my fixes on CVS and rebuild on koji)

Comment 6 Allisson Azevedo 2007-08-03 18:40:24 UTC
Mamoru, your scratch build don't generate .src.rpm output, please release your
.src.rpm

Comment 7 Mamoru TASAKA 2007-08-03 18:46:27 UTC
(In reply to comment #6)
> Mamoru, your scratch build don't generate .src.rpm output, please release your
> .src.rpm

Oops, sorry. Available on
http://koji.fedoraproject.org/scratch/mtasaka/task_88013/

Comment 8 Allisson Azevedo 2007-08-03 19:17:17 UTC
Build OK, http://koji.fedoraproject.org/koji/taskinfo?taskID=88131

Thanks Mamoru.


Note You need to log in before you can comment on or make changes to this bug.