Bug 24911 - Netscape can't be started up in Japanese mode
Netscape can't be started up in Japanese mode
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-24 23:44 EST by Bill Huang
Modified: 2014-03-16 22:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-05 19:15:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Huang 2001-01-24 23:44:51 EST
Install qa0124.0 everything in NFS GUI mode,selecting Japanese installar
and Japanese default enviroment.Reboot the system,Japanese netscape exit
abnormally after confirmed.


[redhat@japan3 redhat]$ netscape
/sbin/pidof: error while loading shared libraries:
/usr/lib/netscape/ns_bogus_locale.so: undefined symbol:
_XmTextFieldSetDestination
mkdir: error while loading shared libraries:
/usr/lib/netscape/ns_bogus_locale.so: undefined symbol:
_XmTextFieldSetDestination
touch: error while loading shared libraries:
/usr/lib/netscape/ns_bogus_locale.so: undefined symbol:
_XmTextFieldSetDestination
sed: error while loading shared libraries:
/usr/lib/netscape/ns_bogus_locale.so: undefined symbol:
_XmTextFieldSetDestination
sleep: error while loading shared libraries:
/usr/lib/netscape/ns_bogus_locale.so: undefined symbol:
_XmTextFieldSetDestination
bus error(core dumped)
[redhat@japan3 redhat]$


But,if run LANG=C netscape,English netsacpe can be properly started up.
Comment 1 Bill Nottingham 2001-01-25 00:23:17 EST
I get the same errors, but netscape runs OK (and displays Japanese
here.)

The errors come from unconditionally setting LD_PRELOAD; we need
to only do that when running the netscape binary itself. That will
be fixed in netscape-common-4.76-6.
Comment 2 Bill Nottingham 2001-01-28 22:19:19 EST
I tried an everything install of beta3, and this worked for me.
Please reopen if this persists with the final beta3.
Comment 3 Eido Inoue 2001-01-28 22:32:05 EST
You are running in Japanese mode, yes? I've seen two (Nakai and Bill's) machines
fail with beta3, as well as my own install of beta-3.

Bill (Huang) can show you a beta-3 tomorrow that fails.
Comment 4 Bill Nottingham 2001-01-29 11:51:40 EST
Aha, I managed to reproduce it. It doesn't like kinput2; if I unset
XMODIFIERS, it starts fine.

Of course, that may not be the best solution, but I'm not sure how
else to fix it.
Comment 5 Bill Huang 2001-01-29 11:56:31 EST
Certainly,I can show the failure.
Comment 6 Glen Foster 2001-01-29 19:06:19 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 7 Bill Nottingham 2001-02-02 15:34:20 EST
It's segfaulting in the Xim code.

Program received signal SIGSEGV, Segmentation fault.
0x089161c7 in _XmImRedisplay () at eval.c:41
41
eval.c: No such file or directory.
	in eval.c
(gdb) 

Unfortunately, I don't know squat about Xim to know whether this is 
an X bug, a bug in how Netscape uses Xim, or a kinput2 bug.
Comment 8 Bill Nottingham 2001-02-02 18:39:05 EST
Whoops, that's not the Xim library, that's netscape's statically
linked motif goop. Fun.

Comment 9 Bill Nottingham 2001-02-05 19:15:26 EST
OK, if we switch back to using -irix-session-management, instead of
-session-management, it starts working again.

I love debugging binary-only crap software. Really.

Fixed in 4.76-8.
Comment 10 Bill Huang 2001-02-12 20:00:49 EST
Fied and verified.

Note You need to log in before you can comment on or make changes to this bug.