Bug 249118 - wrong product version displayed in java console menu
wrong product version displayed in java console menu
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.0.4
i386 Linux
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 19:32 EDT by Marc Sauton
Modified: 2015-01-04 18:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 12:11:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Sauton 2007-07-20 19:32:52 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. get a fc6 system, get fds 1.0.4 from fedoraproject
2. install fds and start
3. java console | Help | About...
4. compare with a slapd instance error log versoin number
  
Actual results:

fds logs:
        Fedora-Directory/1.0.4 B2006.312.1539
        ms-test0.usersys.redhat.com:389 (/opt/fedora-ds/slapd-ms-test0)

[20/Jul/2007:08:35:38 -0700] - Fedora-Directory/1.0.4 B2006.312.1539 starting up
[20/Jul/2007:08:35:39 -0700] - slapd started.  Listening on All Interfaces port
389 for LDAP requests


java console | Help | About...
A popup window says "Fedor Directory Server 1.0.3"

Expected results:

1.0.4 or what ever is the actual product version, as show in the logs

Additional info:

cn=config is correct
nsslapd-versionstring: Fedora-Directory/1.0.4
Comment 2 hugo.etievant 2008-10-06 07:14:05 EDT
i have the same problem : the Java Console show the previous version of DS installed on server

log into linux server system show the good info about version

problem is due to an attribut (serverversionnumber) in an entry (cn=slapd-myinstance,cn=fedora directory server,cn=server group,cn=myinstance.myhost.com,ou=myhost.com,o=netscaperoot) in the config tree of the directory that is not correctly updated during yum update fedora-ds

can you fix this ?
Comment 3 Rich Megginson 2008-10-08 12:11:23 EDT
Fedora DS 1.1.2 and later - the setup-ds-admin.pl command has a -u (--update) option which will fix these console reported versions.

Note You need to log in before you can comment on or make changes to this bug.