Bug 249155 - evince does not correctly display pdf (unless you select text)
Summary: evince does not correctly display pdf (unless you select text)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-21 16:05 UTC by Rolf Linder
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: Fedora8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 15:46:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pdf which is not correctly displayed (5.15 MB, application/pdf)
2007-07-21 16:05 UTC, Rolf Linder
no flags Details
Texas Instruments TPS65020 Datasheet (1.17 MB, application/pdf)
2007-08-03 11:09 UTC, Marcel Ziswiler
no flags Details
Arbitron National Satellite Report (249.27 KB, application/pdf)
2007-10-24 21:16 UTC, Adam D. Ligas
no flags Details

Description Rolf Linder 2007-07-21 16:05:27 UTC
Description of problem:


Version-Release number of selected component (if applicable):

kernel 2.6.21-1.3228.fc7
evince-0.8.2-1.fc7

I'm expiriencing serious problems with evince since fedora 7. there exists many
"types" of pdf's which evince cannot display. sometimes there seems to be no
content, sometimes there is a cryptic view of it.

after you select the text you can read it right way. these problems were not
existing in fc6.


How reproducible:
on the specific pdfs always

Steps to Reproduce:
1. open some type of pdfs
2.
3.
  
Actual results:

wrong display (unless you select text)


Expected results:
correct display of pdf


Additional info:

attached you can find a pdf which cannot be correctly displayed....if I open the
first page I can see only "pock" if I select text I can see the whole text
"Poket PC Phone"....

Comment 1 Rolf Linder 2007-07-21 16:05:35 UTC
Created attachment 159727 [details]
pdf which is not correctly displayed

Comment 2 Borut Semenic 2007-07-30 09:29:11 UTC
A can confirm this bug

This files can be normally viewed with xpdf



Comment 3 Marcel Ziswiler 2007-08-03 11:09:17 UTC
Created attachment 160599 [details]
Texas Instruments TPS65020 Datasheet

I can confirm this bug as well. This Texas Instruments TPS65020 Datasheet that
can be downloaded from
http://focus.ti.com/docs/prod/folders/print/tps65020.html does not seem to
render right in evince (evince-0.8.2-1.fc7). As soon as some text is selected
it magically appears. Same PDF works just fine with xpdf.

Comment 4 Adam D. Ligas 2007-10-24 21:15:37 UTC
I can also confirm this bug.  See the attached Arbitron Satellite Radio ratings
PDF.  Evince fails to render the text in the tables from page 4 onward.

The document works properly in Adobe Acrobat Reader 7.0 and 8.0 on Windows.

Comment 5 Adam D. Ligas 2007-10-24 21:16:58 UTC
Created attachment 236681 [details]
Arbitron National Satellite Report

Comment 6 Rolf Linder 2007-11-11 11:33:27 UTC
Just for Information. On the now published Fedora8 the bug doesent exist any
more....



Comment 7 Rolf Linder 2007-11-13 15:46:35 UTC
Due to this is solved in Fedora8 I'll close this bug.


Note You need to log in before you can comment on or make changes to this bug.