Bug 249164 - Disable new version checks in mugshot
Disable new version checks in mugshot
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mugshot (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-21 15:54 EDT by Angel Marin
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-21 21:03:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Angel Marin 2007-07-21 15:54:32 EDT
Mugshot keeps asking end users to download new releases for a software installed
through a repository and that they can't update.

These new version dialogs popping up are kind of annoying and should be disabled.
Comment 1 Ignacio Vazquez-Abrams 2007-07-21 15:57:37 EDT
All it does is open a webpage where you can download a newer package. Is this
really a problem?
Comment 2 Angel Marin 2007-07-21 16:38:54 EDT
Having a dialog in the middle of my desktop several times a day (each time
laptop comes back from suspend or wireless gets reconnected) asking me to do
something that I can't do (and no way to disable) is really a problem. If it
were a libnotify timed dialog it wouldn't be a problem, but as it is now it's
plainly annoying and should be disabled.

At least firefox and thunderbird ship with their update notification disabled.
Comment 3 Owen Taylor 2007-07-21 21:03:32 EDT
I'm not sure how this is relevant to Red Hat / Fedora bugzilla, since
the packages available for Fedora are as new or newer than the versions
advertised by the dialog.

(Maybe this is a a request to push 1.1.46 to f7-updates, which yes, we 
should do, though you can download the exact same packages from 
download.mugshot.org)

If you aren't using Fedora, then the appropriate place for a bug report
is bugzilla.mugshot.org. The problem with reminders when there are no
newer packages available for your distro is:

 http://bugzilla.mugshot.org/show_bug.cgi?id=1105

Using a stacker notification block for upgrade notificaitons is:

 http://bugzilla.mugshot.org/show_bug.cgi?id=1204
Comment 4 Owen Taylor 2007-07-21 21:07:46 EDT
I guess a third thing you might have been saying is:

 Fedora packages don't need upgrade suggestions because the user is using
 yum. 

There is some justice in that, but we are often rolling out new features
with client and server pieces, and it's sort of tricky to find a good way
to tell the user "check out this new feature" when they might not have
a new client yet. (You'd have to somehow wait until the client was installed
and then show the client.)

Expect future changes in how we package the mugshot client in any case
as we work on the broader "online desktop" (http://online-desktop.org)
vision.
Comment 5 Angel Marin 2007-07-22 02:58:11 EDT
Well I hardly see this as an upstream issue, they have a check for new releases
in their software, so I guess they want it that way.

But as a fedora user I already have an update mechanism built in and enabled by
default, so I don't need/want individual packages asking me to update them;
yum-updatesd already does this for all of them (and as an end user why would I
have root password?). And no, this is not a request to push latest version to
f7-updates, I just don't care that much about the release numbers (I trust each
package maintainer on picking them for me and pushing them when they feel like
it); I'm just annoyed about a dialog bugging me over a dozen times a day.

I'm not talking about a random package downloaded and installed from a random
site, it a package installed from the fedora7 repo, so it should behave as the
rest of them. I don't get update notifications from firefox or thunderbird or
oo.org, they are all packaged in fedora with their autoupdate features disabled.

So if you want to tell the user 'hey check this new cool release', it's not
tricky, just push it to f7-updates. Firefox opens the release notes in the first
run after an update, but that part is an upstream issue.

But if you don't see the inconsistency with the rest of fedora packages, that's
ok too; I don't care that much either to keep ranting about one single dialog.

Note You need to log in before you can comment on or make changes to this bug.