Bug 249166 - 2.6.22.1-27.fc7 does not recognize attached Hard Drives
Summary: 2.6.22.1-27.fc7 does not recognize attached Hard Drives
Status: CLOSED DUPLICATE of bug 249154
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i686 Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-21 20:25 UTC by Daniel Duggan
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 17:09:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg and fdisk contents 2.6.22 and 2.6.21 kernel (41.64 KB, text/plain)
2007-07-22 14:11 UTC, Daniel Duggan
no flags Details

Description Daniel Duggan 2007-07-21 20:25:06 UTC
Description of problem:
2.6.22.1-27.fc7 does not recognize / detect attached Hard Drives, which are
connected to a Highpoint 370/372 on-board controller - Both drives are  jbod and ide

Version-Release number of selected component (if applicable):
kernel 2.6.22.1-27.fc7 

How reproducible:
100 %

Steps to Reproduce:
1. Boot from the kernel 2.6.22.1-27.fc7 
2. Boot process shows that pre-existing /etc/fstab entries for /dev/sdc1 and
/dev/sdd1 do not exist
3. fdisk -l does not show the drives as being present with the 2.6.22.1-27.fc7 
kernel
  
Actual results:
Failure to recognize / detect the attached drives, as such it is not possible to
mount them. 
This is a regression from all kernels from FC2 on-ward
The drives are recognized / detected correctly and mount at boot time with both the 
2.6.21-1.3228.fc7
and
2.6.21-1.3194.fc7
kernels
fdisk -l with both the 2.6.21 kernels result in detecting the hard drives correctly.

Expected results:
That the /etc/fstab entries for the attached drives would be recognized and
mount properly at boot time.
Also, that they would be detected with the command fdisk -l


Additional info:
One disk has an ext3 file format and the other has a fat32 file format.

Should you need any additional information please let me know and I will forward
it as soon as possible.

Regards

Comment 1 Daniel Duggan 2007-07-22 14:11:33 UTC
Created attachment 159744 [details]
dmesg and fdisk contents 2.6.22 and 2.6.21 kernel

Comment 2 Chuck Ebbert 2007-07-23 17:09:41 UTC

*** This bug has been marked as a duplicate of 249154 ***


Note You need to log in before you can comment on or make changes to this bug.