Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 249167 - Sound no longer works on SiS SI7012 (intel8x0)
Sound no longer works on SiS SI7012 (intel8x0)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 246410 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-21 16:27 EDT by Andrew Overholt
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.14-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-12 20:43:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig (41.90 KB, text/plain)
2007-07-21 16:27 EDT, Andrew Overholt
no flags Details

  None (edit)
Description Andrew Overholt 2007-07-21 16:27:27 EDT
Description of problem:
Clean install of F7 on empty hard disk results in no sound.  Fedora Core 4
through 6 (I can't remember earlier) had no problem with this on-board sound.

Version-Release number of selected component (if applicable):
alsa-lib-1.0.14-0.4.rc3.fc7

How reproducible:
Always.  I've tried various options in alsamixer and looked online but muting
different devices doesn't work for me.

Additional info:
I'll attach scsconfig.log.
Comment 1 Andrew Overholt 2007-07-21 16:27:28 EDT
Created attachment 159730 [details]
scsconfig
Comment 2 Andrew Overholt 2007-07-21 16:28:00 EDT
scsrun.log:

------- System Config Soundcard Log --------
Sat Jul 21 14:22:35 EDT 2007

aplay: main:545: audio open error: No such file or directory
Running from command-line...
Comment 3 Martin Stransky 2007-07-25 08:14:59 EDT
Can you please try to run "aplay /usr/share/sounds/phone.wav" in terminal? (or
try to run any other wav file). Is there any error output?
Comment 4 Martin Stransky 2007-07-25 08:18:08 EDT
*** Bug 246410 has been marked as a duplicate of this bug. ***
Comment 5 Martin Stransky 2007-07-25 08:20:04 EDT
you can try to update your drivers / packages to 1.0.14 final (todo is at
http://people.redhat.com/stransky/alsa/)
Comment 6 Andrew Overholt 2007-07-25 14:18:04 EDT
There's no error output when using aplay.

I tried:

yum --enablerepo=atrpms update alsa-oss{,-libs} alsa-lib alsa-oss alsa-utils

but there were no updates.  I see ATrpms has lots of alsa-kmdl and such.  What
do I need to do to get the latest?  I'm on F7.
Comment 7 Martin Stransky 2007-07-26 07:00:46 EDT
I recommend you to compile them yourself from alsa-drivers tar-ball. I've never
used that packages from ATrpms.
Comment 8 Andrew Overholt 2007-08-12 20:43:15 EDT
This seems to be fixed in 1.0.14.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.