Bug 249175 - [OnStream] Long delay at boot probing 2nd ATA port
[OnStream] Long delay at boot probing 2nd ATA port
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Alan Cox
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-22 01:23 EDT by jdever
Modified: 2008-03-15 14:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-15 14:18:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg at boot (19.54 KB, text/plain)
2007-07-22 01:23 EDT, jdever
no flags Details
Recent dmesg (2007-09-20) (18.94 KB, application/octet-stream)
2007-09-21 02:32 EDT, jdever
no flags Details
Output of lspci -vvxxx (24.34 KB, text/plain)
2007-09-21 22:46 EDT, jdever
no flags Details
Output of lsmod (3.12 KB, text/plain)
2007-09-21 22:47 EDT, jdever
no flags Details
Output of dmidecode (13.75 KB, text/plain)
2007-09-21 22:48 EDT, jdever
no flags Details
dmesg - 2.6.22.5-85 kernel (18.40 KB, text/plain)
2007-09-29 05:20 EDT, jdever
no flags Details
dmesg - 2.6.23.1-10 kernel (20.41 KB, text/plain)
2007-10-30 20:21 EDT, jdever
no flags Details
dmesg - latest kernal (2.06 KB, text/plain)
2008-03-11 04:06 EDT, jdever
no flags Details

  None (edit)
Description jdever 2007-07-22 01:23:43 EDT
Description of problem:

Ever since upgrading from FC6 to F7 there is a long (30 second+) delay in
booting with the following error messages:

ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.01: cmd a0/01:00:00:00:00/00:00:00:00:00/b0 tag 0 cdb 0x12 data 36 in
         res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
ata2: port failed to respond (30 secs, Status 0xd0)
ata2.01: revalidation failed (errno=-22)


Version-Release number of selected component (if applicable):

Kernel 2.6.21-1.3228.fc7


How reproducible:

100%
Error is consistent on every boot.


Steps to Reproduce:
1.  Boot Fedora 7
2.
3.
  
Actual results:

Error messages at boot and 30+ second delay


Expected results:


Additional info:

Hardware is an old (7 year) Dell Dimension 8200 Desktop.
The device connected to the port that's giving the error is an old OnStream
DI-30 tape drive.  I don't care to use this under Linux but still have
occasional use for it in Windows (dual boot).  I have no SATA drives or SATA
ability.  Just old fashioned PATA.

Nothing else seems to be effected.  The wait is just very annoying.

dmesg at boot attached
Comment 1 jdever 2007-07-22 01:23:43 EDT
Created attachment 159734 [details]
dmesg at boot
Comment 2 Christopher Brown 2007-09-20 06:57:56 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 3 jdever 2007-09-21 02:32:05 EDT
Created attachment 201701 [details]
Recent dmesg (2007-09-20)
Comment 4 jdever 2007-09-21 02:35:18 EDT
Hi there!

Thanks so much for replying.  Yes I'm still having the same problem.  Doesn't
seem to effect operation.  Just a long delay at boot.  I've attached a more
recent copy of dmesg above.   If there's anything else I can do to help let me
know.  I'm a bit new to bugzilla too bear with me.

Jim
Comment 5 Christopher Brown 2007-09-21 04:41:56 EDT
Hello Jim,

Thanks for the update. Could you run the following commands and attach them (as
text/plain) to this bug:

# lspci -vvxxx
# lsmod
# dmidecode (you may have to install this)

If you are able to capture the error message at boot that would be a help too.

Cheers
Chris
Comment 6 jdever 2007-09-21 22:46:56 EDT
Created attachment 202901 [details]
Output of lspci -vvxxx

Hi Chris,

Error message at boot (captured by hand transcription after a CTRL-S) is:

ata2.01: exception Emask 0x0 SAct SErr 0x0 action 0x2 frozen
ata2.01: cmd a0:01:00:00:00:00/00:00:00:00:00/b0 tag 0 cdb 0x12 data 48 in
ata2.01: revalidation failed (errno=-22)
ata2:01: revalidation failed (errno=-22)

I think all these lines are echoed in dmesg with the second line being
truncated on the screen.

Attached files follow containing outputs of:

lspci -vvxxx
lsmod
dmidecode

Thanks again,
Jim
Comment 7 jdever 2007-09-21 22:47:35 EDT
Created attachment 202911 [details]
Output of lsmod
Comment 8 jdever 2007-09-21 22:48:06 EDT
Created attachment 202921 [details]
Output of dmidecode
Comment 9 Christopher Brown 2007-09-22 13:23:46 EDT
Does it help by adding irqpoll to the boot parameters? Here is the cause for the
pause from your dmesg:

ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.01: cmd a0/01:00:00:00:00/00:00:00:00:00/b0 tag 0 cdb 0x12 data 48 in
         res 40/00:02:00:24:00/00:00:00:00:00/b0 Emask 0x4 (timeout)
ata2: port is slow to respond, please be patient (Status 0xd0)
ata2: device not ready (errno=-16), forcing hardreset
ata2: soft resetting port
ata2.01: failed to IDENTIFY (device reports invalid type, err_mask=0x0)
ata2.01: revalidation failed (errno=-22)
ata2.01: limiting speed to MWDMA2:PIO3
ata2: failed to recover some devices, retrying in 5 secs
ata2: soft resetting port
ata2.01: failed to IDENTIFY (device reports invalid type, err_mask=0x0)
ata2.01: revalidation failed (errno=-22)
ata2.01: disabled
ata2: failed to recover some devices, retrying in 5 secs
ata2.00: configured for UDMA/33
ata2: EH complete

so try adding:

options libata pata_dma=0

to your modprobe.conf file to disable DMA.

I note in your original post to the fedora mailing list:

http://www.redhat.com/archives/rhl-list/2007-June/msg00401.html

where Alan Cox mentioned that the hardware is reporting incorrect values to the
kernel:

http://www.redhat.com/archives/rhl-list/2007-June/msg01754.html

and if this is the case it might be difficult to resolve however I'll re-assign
this if the above doesn't work for you.

Cheers
Chris
Comment 10 Chuck Ebbert 2007-09-24 13:41:09 EDT
Bugs with ATAPI tape drives are being worked on upstream, they are known to be
broken. OnStream may need additional changes, though...
Comment 11 jdever 2007-09-26 04:45:47 EDT
Chris:

Well the addition to modprobe.conf didn't work.  Thanks for digging up the
conversation with Alan in the archives as well.  I wish I there was some way to
just make it not probe that device.  Thanks for your help!


Chuck:

Thanks for your input as well.  I just found it strange that Fedora Core 6
worked (as far as no error messages) and Fedora 7 did not.

So what do you need next from me if anything?  Just to know that the problem is
recognized and be patient?

Thanks to both of you and if I can help at all let me know!

Jim
Comment 12 Christopher Brown 2007-09-26 16:53:56 EDT
Could you try the same option again in modprobe.conf but with a rawhide kernel?
Comment 13 jdever 2007-09-29 05:16:25 EDT
With the latest kernel that I downloaded today (2.6.22.5-85) I no longer have
the error message from the probe of the OnStream device.

However, I noticed a significant slowdown in disk I/O.  From this clip of dmesg
it looks like it's using PIO Mode 4 for all IDE devices now.  I've removed the
options statement from modprobe.conf.  I've included a clip of dmesg from both
kernels and will attach dmesg from the latest kernel.

Again let me know if I can do anything else.  

Thanks,
Jim

--- Segment of current dmesg follows ---

ata1.00: configured for PIO4
ata1.01: configured for PIO4
ata2.00: ATAPI: PLEXTOR DVDR   PX-708A, 1.12, max UDMA/33
ata2.01: ATAPI:  OnStream DI-30, 1.09, max MWDMA2
ata2.00: configured for PIO4
ata2.01: configured for PIO4
--- End of dmesg ---

--- Segment of dmesg from previous kernal ---

ata1.00: configured for UDMA/100
ata1.01: configured for UDMA/100
ata2.00: ATAPI: PLEXTOR DVDR   PX-708A, 1.12, max UDMA/33
ata2.01: ATAPI:  OnStream DI-30, 1.09, max MWDMA2
ata2.00: configured for UDMA/33
ata2.01: configured for MWDMA2
--- End of dmesg ---
Comment 14 jdever 2007-09-29 05:20:07 EDT
Created attachment 211281 [details]
dmesg - 2.6.22.5-85 kernel

Output of Current dmesg - 2.6.22.5-85 Kernel
Comment 15 Chuck Ebbert 2007-10-01 14:41:11 EDT
pata_dma has more options now. Try pata_dma=1 to use DMA only for disk devices.
The CD drive will still use PIO, though.
Comment 16 jdever 2007-10-02 04:41:53 EDT
After upgrading to 2.6.22.9-91 kernel:

Using no pata_dma options, I no longer get the error message.  The disk drives
are set to UDMA/100 but both the CD drive and the OnStream are set at PIO.  Any
chance of the DVD-ROM being set for UDMA/33 as it was in the previous kernels?

Thanks,
Jim

--- Clip from current DMESG ---
ata1.00: configured for UDMA/100
ata1.01: configured for UDMA/100
ata2.00: ATAPI: PLEXTOR DVDR   PX-708A, 1.12, max UDMA/33
ata2.01: ATAPI:  OnStream DI-30, 1.09, max MWDMA2
ata2.00: configured for PIO4
ata2.01: configured for PIO4
---
Comment 17 jdever 2007-10-30 20:15:54 EDT
Kernel 2.6.23.1-10:

I'm back to my original problem.

ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.01: cmd a0/01:00:00:00:00/00:00:00:00:00/b0 tag 0 cdb 0x12 data 48 in
         res 40/00:02:00:24:00/00:00:00:00:00/b0 Emask 0x4 (timeout)
ata2: port is slow to respond, please be patient (Status 0xd0)
ata2: device not ready (errno=-16), forcing hardreset
ata2: soft resetting port
ata2.01: failed to IDENTIFY (device reports invalid type, err_mask=0x0)
ata2.01: revalidation failed (errno=-22)
ata2.01: limiting speed to MWDMA2:PIO3
ata2: failed to recover some devices, retrying in 5 secs
ata2: soft resetting port
ata2.01: failed to IDENTIFY (device reports invalid type, err_mask=0x0)
ata2.01: revalidation failed (errno=-22)
ata2.01: disabled
ata2: failed to recover some devices, retrying in 5 secs

Comment 18 jdever 2007-10-30 20:21:18 EDT
Created attachment 243891 [details]
dmesg - 2.6.23.1-10 kernel


Full dmesg output if needed
Comment 19 Alan Cox 2007-12-03 12:32:20 EST
Ok first set of patches now targetted at 2.6.24. Reported to fix a variety of
tape drives which don't quite follow the ATAPI spec.
Comment 20 Alan Cox 2008-03-10 07:59:49 EDT
Does the 2.6.24 kernel fix this for you ?
Comment 21 jdever 2008-03-11 04:06:59 EDT
Created attachment 297579 [details]
dmesg - latest kernal

Looks like it's fixed nicely!  No delay, no error message.

I attached a section of dmesg as well just for completeness.

Thanks so much guys!

Jim

Note You need to log in before you can comment on or make changes to this bug.