Bug 249177 - loading of rt61pci cause dead freezze
loading of rt61pci cause dead freezze
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-22 02:41 EDT by Knut J BJuland
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 07:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modules loaded no nvidia (3.86 KB, application/octet-stream)
2007-07-22 02:41 EDT, Knut J BJuland
no flags Details

  None (edit)
Description Knut J BJuland 2007-07-22 02:41:10 EDT
Description of problem:
When load rt61pci or starting wlan0 the pc freez in X or in init 3

Version-Release number of selected component (if applicable):
kernel-2.6.22.1-27.fc7


How reproducible:
Every time

Steps to Reproduce:
1. modprobe rt61pci +mac
2. start wpa_supplicant
3.
  
Actual results:

irq 11: nobody cared (try booting with the "irqpoll" option)
 [<c0455e82>] __report_bad_irq+0x36/0x75
 [<c045606f>] note_interrupt+0x1ae/0x1eb
 [<c0455566>] handle_IRQ_event+0x1a/0x3f
 [<c04569ac>] handle_level_irq+0x95/0xc5
 [<c0456917>] handle_level_irq+0x0/0xc5
 [<c04071f7>] do_IRQ+0xac/0xd1
 [<c05bef90>] nlmsg_notify+0x3f/0x6a
 [<c040592b>] common_interrupt+0x23/0x28
 [<c042d3d0>] __do_softirq+0x54/0xc1
 [<c04070f3>] do_softirq+0x59/0xb1
 [<c042ffcb>] lock_timer_base+0x19/0x35
 [<c0456917>] handle_level_irq+0x0/0xc5
 [<c042d298>] irq_exit+0x38/0x6b
 [<c0407208>] do_IRQ+0xbd/0xd1
 [<c043003b>] del_timer_sync+0xa/0x14
 [<c060bb5e>] schedule_timeout+0x79/0x8f
 [<c040592b>] common_interrupt+0x23/0x28
 [<d8a4f162>] rt61pci_config_bssid+0x3/0x60 [rt61pci]
 [<d89f82d8>] rt2x00lib_config_interface+0x4f/0x82 [rt2x00lib]
 [<d8a0a966>] __ieee80211_if_config+0xf9/0x105 [mac80211]
 [<d8a0f09e>] ieee80211_open+0x2bd/0x2ff [mac80211]
 [<c05ad4e9>] netdev_run_todo+0x1ea/0x1f1
 [<c05acb95>] dev_open+0x2e/0x68
 [<c05ab667>] dev_change_flags+0x4c/0xfa
 [<c05e8efe>] devinet_ioctl+0x250/0x56e
 [<c04edb98>] copy_to_user+0x34/0x48
 [<c05a1e0b>] sock_ioctl+0x19f/0x1be
 [<c05a1c6c>] sock_ioctl+0x0/0x1be
 [<c04848cd>] do_ioctl+0x21/0xa0
 [<c0484b83>] vfs_ioctl+0x237/0x249
 [<c0484be1>] sys_ioctl+0x4c/0x67
 [<c0404f8e>] syscall_call+0x7/0xb
 =======================
handlers:
[<d8abf4bd>] (bttv_irq+0x0/0x733 [bttv])
[<d8a4eddb>] (rt61pci_interrupt+0x0/0x31a [rt61pci])
Disabling IRQ #11


Expected results:

Rt61pci should load 
Additional info:
Comment 1 Knut J BJuland 2007-07-22 02:41:10 EDT
Created attachment 159735 [details]
modules loaded no nvidia
Comment 2 Ivo van Doorn 2007-07-23 18:24:16 EDT
I am not sure what version of rt2x00 is shipped at this moment with Fedora,
What does "modinfo rt61pci" report?
Comment 3 Knut J BJuland 2007-07-24 02:33:11 EDT
modinfo rt61pci 
filename:      
/lib/modules/2.6.22.1-27.fc7/kernel/drivers/net/wireless/mac80211/rt2x00/rt61pci.ko
license:        GPL
firmware:       rt2661.bin
firmware:       rt2561s.bin
firmware:       rt2561.bin
description:    Ralink RT61 PCI & PCMCIA Wireless LAN driver.
version:        2.0.2
author:         http://rt2x00.serialmonkey.com
srcversion:     BF12469380036164F121977
alias:          pci:v00001814d00000401sv*sd*bc*sc*i*
alias:          pci:v00001814d00000302sv*sd*bc*sc*i*
alias:          pci:v00001814d00000301sv*sd*bc*sc*i*
depends:        rt2x00pci,rt2x00lib,mac80211,eeprom_93cx6
vermagic:       2.6.22.1-27.fc7 SMP mod_unload 686 4KSTACKS 
Comment 4 Ivo van Doorn 2007-07-24 05:46:35 EDT
In what mode are you trying to set the interface?
managed, adhoc or master mode?
Comment 5 Knut J BJuland 2007-07-24 08:48:40 EDT
Managed
Comment 6 Knut J BJuland 2007-07-25 16:31:57 EDT
IO can get to crash by issusing wpa_supplicant -dd -Dwext -iwlan0
-c/etc/wpa_supplicant.conf
Comment 7 Ivo van Doorn 2007-07-25 16:55:56 EDT
John,

I have just released rt2x00 2.0.4 which contains the possible fix for this 
issue.
I can't be too sure at this time, since although Knut can reproduce this 
reliable, he is also the only user who could have reproduced this.
Reports about similar issues have so far been extremely rare...

So lets hope 2.0.4 will do the trick :)
Comment 8 Knut J BJuland 2007-07-26 07:17:29 EDT
It works with 2.6.21.1-36.fc7

Note You need to log in before you can comment on or make changes to this bug.