Bug 249184 - Qt4 configuration appears outside the preferences hierarchy
Summary: Qt4 configuration appears outside the preferences hierarchy
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt4   
(Show other bugs)
Version: 10
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-22 10:02 UTC by Sergio Pascual
Modified: 2009-02-25 12:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 12:16:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sergio Pascual 2007-07-22 10:02:26 UTC
Description of problem:
After installing qt4, the configuration appears directly in System
-> Preferences, instead of inside one of the categories of Preferences (Look and
Feel, Hardware, etc..)

Version-Release number of selected component (if applicable):
qt4-x11-4.3.0-8.fc7

How reproducible:
Always

Steps to Reproduce:
1. Install qt4
2. Expand the System -> Preferences menu
3.
  
Actual results:
The configuration of qt4 appears in System -> Preferences

Expected results:
The configuration of qt4 should appear in one of the System ->
Preferences submenus

Additional info:
I filled the bug against qt4 but the desktop entry belongs to qt4-x11. That
package doesn't appear in the packages list.

Comment 1 Sergio Pascual 2007-10-16 06:16:38 UTC
The same problem continues in qt4-4.3.2-1.fc7

Comment 2 Sergio Pascual 2008-11-05 10:04:27 UTC
In qt4-qtconfig.desktop you only have to change

Categories=Qt;Settings;

by

Categories=Qt;Settings;DesktopSettings; 

to put this in the Look and Feel category, that seems appropriated to me.

Comment 3 Sergio Pascual 2008-12-19 08:31:11 UTC
Well, now qt4-qtconfig.desktop has a NoDisplay=true so it doesn't appear as an entry anymore. Works for me.


Note You need to log in before you can comment on or make changes to this bug.