Bug 249196 - OO.o can not handle fonts with more than the 4 legacy styles
Summary: OO.o can not handle fonts with more than the 4 legacy styles
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: x-fontstyle-support
TreeView+ depends on / blocked
 
Reported: 2007-07-22 13:12 UTC by Nicolas Mailhot
Modified: 2009-06-27 15:45 UTC (History)
1 user (show)

Fixed In Version: 2.2.1-18.8.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 10:07:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 79878 None None None Never

Description Nicolas Mailhot 2007-07-22 13:12:18 UTC
cf upstream bug

Comment 1 Caolan McNamara 2007-07-23 11:10:07 UTC
I wonder if the problem is the dialog deciding not to show them, of if we are
mangling multiple styles together. 

The bottom-most layer is finding them all, and knows they are all Deja Vu Sans,
e.g. see vim ~/.openoffice.org2/user/psprint/pspfontcache so we have it right at
the bottom, we're loosing it somewhere between font detection and UI.

FontStyleBox::Fill in svtools/source/control/ctrlbox.cxx is a good place to
start looking at this.

Comment 2 Nicolas Mailhot 2007-07-23 11:32:14 UTC
IIRC fonts have two style fields : a legacy one with the 4 legacy styles and a
new one with more possibilities. Somewhere in OO.o code the fonts must be
accessed through the legacy field, which puts all bold variants together, all
italic variants together, etc.

That it shows 5 styles not 4 is probably because extralight is not sharing the
same font name as the other variants.

Comment 3 Caolan McNamara 2007-07-24 12:25:40 UTC
sent a proposed patch upstream and added it to fedora cvs, will be in next build. 

but I will pull it if there is some unknown side-effect that I'm currently
unaware of that is a reason why we don't already do this.

Comment 4 Fedora Update System 2007-07-30 16:58:39 UTC
openoffice.org-2.2.1-18.1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Caolan McNamara 2007-08-10 10:07:39 UTC
Done in rawhide as 2.2.1-18.8.fc8, e.g. DejaVu LGC Sans shows a stack of 9
options now

Comment 6 Torsten Rausche 2007-10-21 13:16:21 UTC
Unfortunately it doesn't work altogether. If you select Condensed (or variants
of Condensed like Condensed Bold) you get the normal Book version instead of the
expected Condensed one. Strangely enough ExtraLight gives you what you would expect.
This also applies to the font selected via GNOME's control center. If you
selected DejaVu LGC Sans Condensed for the UI then OO.o will use DejaVu LGC Sans
Book for its UI. If you selected DejaVu LGC Sans ExtraLight then OO.o will use it.


Comment 7 Caolan McNamara 2007-10-21 13:25:32 UTC
The upstream issue covers this topic and related subproblems, various other bits
of OOo need to change their assumptions, a larger scale task than I can
undertake on my own.


Note You need to log in before you can comment on or make changes to this bug.