Bug 249213 - Takes several hours to print a single US Letter page with cups-1.2.12
Takes several hours to print a single US Letter page with cups-1.2.12
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
Depends On:
Blocks: FC6Update
  Show dependency treegraph
Reported: 2007-07-22 15:08 EDT by Daniel Berrange
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 1.2.12-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-30 05:31:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2007-07-22 15:08:30 EDT
Description of problem:
After the recent update to cups-1.2.12, a regular US Letter photo quality print
on my Canon ip6700d takes many hours to complete, instead of the previous 30-60

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Insert a single sheet of paper
2. Queue a print job
Actual results:
Prints one row of image every 10 seconds, complete job takes many hours

Expected results:
Job finished in < 1 minute

Additional info:
The cnijfilter-* RPMs are the Canon supplied prorietry addons. I do not believe
these are the problem though because they merely do the data conversion - the
sending of data to the USB device is still being done by regular CUPs.

I straced the  /usr/lib/cups/backend/usb process that is sending data to the
device and after every single write() it gets EAGAIN, and then does a 1 second
sleep. So its only sending 8192 bytes of data each second, explaining why it
takes many hours to send the 40 MB print job.

I looked at the source for the USB backend at it looks like the 'sleep(1)' was
introduced by a custom Fedora patch ontop of regular upstream


Removing this patch & re-building the cups RPM solved the problems & printing is
now fast again.
Comment 1 Fedora Update System 2007-07-23 11:45:08 EDT
cups-1.2.12-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 2 Tim Waugh 2007-07-30 05:31:22 EDT
Have you tried 1.2.12-2.fc7?  Does it fix the problem for you?

(To upgrade to it, use:
  yum --enablerepo=updates-testing update 'cups*'
 and say 'y' when prompted.)
Comment 3 Daniel Berrange 2007-07-30 07:28:27 EDT
I've not tested FC7 rpms because I reported this against FC6 which is the OS on
the machine I print from. That said it appears there's now a cups update for FC6
too so I'll give that a try.
Comment 4 Daniel Berrange 2007-08-04 11:24:28 EDT
Confirmed that the cups-1.2.12-2.fc6 build has resolved the problems
Comment 5 Fedora Update System 2007-08-10 18:22:48 EDT
cups-1.2.12-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.