Bug 249215 - kernel.x86_64 2.6.22.1-27.fc7 breaks mlocate updatedb
Summary: kernel.x86_64 2.6.22.1-27.fc7 breaks mlocate updatedb
Status: CLOSED DUPLICATE of bug 242715
Alias: None
Product: Fedora
Classification: Fedora
Component: mlocate   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-22 20:56 UTC by Daniel Duggan
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 14:59:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the compressed contents of strace -v -o log updatedb (766.63 KB, application/x-bzip)
2007-07-22 20:56 UTC, Daniel Duggan
no flags Details

Description Daniel Duggan 2007-07-22 20:56:15 UTC
Description of problem:
Executing updatedb results in : 
# updatedb
updatedb: src/updatedb.c:721: scan_cwd: Assertion `name_size > 1' failed.
Aborted

Version-Release number of selected component (if applicable):
# updatedb --version
updatedb (mlocate) 0.16
$ rpm -aq | grep mlocate
mlocate-0.16-1


How reproducible:
100 % when using kernel.x86_64 2.6.22.1-27.fc7

Steps to Reproduce:
1.run updated
2.
3.
  
Actual results:
# updatedb
updatedb: src/updatedb.c:721: scan_cwd: Assertion `name_size > 1' failed.
Aborted

Expected results:
updatedb should run cleanly

Additional info:
Attached in compressed format the output of :
strace -v -o log updatedb

updatedb runs cleanly on both of the kernels below:
kernel.x86_64  2.6.21-1.3228.fc7      
kernel.x86_64  2.6.21-1.3194.fc7

Comment 1 Daniel Duggan 2007-07-22 20:56:16 UTC
Created attachment 159751 [details]
the compressed contents of strace -v -o log updatedb

Comment 2 Miloslav Trmač 2007-07-23 14:59:40 UTC
Thanks for your report.  This bug is already tracked as #242715.

*** This bug has been marked as a duplicate of 242715 ***


Note You need to log in before you can comment on or make changes to this bug.