Bug 249217 - Kernel 2.6.22.1-27.fc7 fails to boot on PS3
Kernel 2.6.22.1-27.fc7 fails to boot on PS3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
ppc64 Linux
low Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-22 18:12 EDT by Jason
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 10:34:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2007-07-22 18:12:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/419.2.1 (KHTML, like Gecko) Safari/419.3

Description of problem:
When attempting to boot kernel 2.6.22.1-27.fc7 on my PS3 I receive the following output after 
selecting the kernel to boot at the kboot prompt:

get memory range:1 
Modified cmdline:root=LABEL=/ video=480p quiet acpi=force 
segment[0].mem:0x17ce000 memsz:8515584 
segment[1].mem:0x1fed000 memsz:16384 
segment[2].mem:0x1ff1000 memsz:3637248 
segment[3].mem0x7bff000 memsz:4096 
UUART: cleanup. 
SYSMGR: cleanup. (close event mask) 


2.6.21-1.3228.fc7 did and still does boot normally.

Version-Release number of selected component (if applicable):
kernel-2.6.22.1-27.fc7

How reproducible:
Always


Steps to Reproduce:
1. Install the kernel from yum
2. Reboot
3.

Actual Results:
New kernel failed to boot

Expected Results:
Should have booted properly

Additional info:
Comment 1 Patrick Clément-Bonhomme 2007-07-27 11:29:04 EDT
I have the same issue as the original reporter. However, I don't have included
the "acpi=force" option at boot.

The newly released kernel (kernel-2.6.22.1-33.fc7) doesn't fix the issue.
Comment 2 David Woodhouse 2007-07-27 11:41:19 EDT
2.6.22-1.37.fc7 or later (when released) should work on PS3 again. When the
build finishes, you should be able to find it from
http://koji.fedoraproject.org/koji/taskinfo?taskID=79448

If you made the mistake of letting the installer use LVM even though it's
pointless, watch out for bug #249672 (hopefully there'll be an updated lvm2
package for that shortly; you'll want that installed before you install the new
kernel, or you'll want to run mkinitrd manually with the new lvm if you install
this kernel first).
Comment 3 Jason 2007-07-28 01:11:00 EDT
I just installed 2.6.22-1.37.fc7 and can confirm that it is booting properly on 
the PS3. Thanks!
Comment 4 Jason 2007-07-28 01:28:49 EDT
When I attempt to run boot-game-os with 2.6.22-1.37.fc7 it spits out the usage 
list and 'ERROR: can't change boot flag' . I had to boot back to 2.6.21-
1.3228.fc7 in order to get it to run properly.

[root@ps3 Desktop]# /sbin/boot-game-os 
Usage:
  other-os-flash-util [-b|-B] [-g|-r] flash_device [boot_loader_img]
  other-os-flash-util -s flash_device
  other-os-flash-util -d flash_device

Options:
  -s   show current settings
  -d   print difference of clock time between game os and linux
  -b   change boot flag : boot game os
  -B   change boot flag : boot linux
  -g   change boot loader format flag : compressed by gzip
  -r   change boot loader format flag : not compressed
ERROR: can't change boot flag
Comment 5 Goffredo Marocchi 2007-07-28 03:50:36 EDT
That is the least of all worries, until they implement reboot and shutdown
properly you still have to keep pressing the power button (once linux has been
halted) till the console shuts down itself. You might as well sit nearby and
turn it on by pressing the power on button for 5+ seconds (keeping it pressed
while it turns on) and that will boot the Game OS with the inconvenience of
having to reset the screen resolution settings.

Jason, do you use LVM ? (I stupidly let the installer use it... :()
Comment 6 David Woodhouse 2007-07-28 04:05:47 EDT
Yes, the lack of reboot/kexec sucks hard. I was expecting that to be fixed 'any
day now' at the time we added PS3 support to F-7, otherwise I'd probably have
refused to support it as I did for FC6.

The utilities mangling the otheros flash area are going to need updating,
because that region now appears as a character device instead of a SCSI disk --
thanks for reminding me of that. I'll do it shortly.

You can find an updated LVM package at
http://david.woodhou.se/lvm2-2.02.24-1.fc7.ps3.ppc.rpm

Comment 7 Jason 2007-07-28 12:57:20 EDT
I do not use LVM. If you hold the button down on the PS3 it also resets the 
video mode to 480i.  

Unfortunately I have an older television which supports 480i on one set of 
connectors (composite, s-video, and one component 'colorstream' set (which only 
does 480i), and 480p/1080i on a separate set of component/DVI connectors. 

Most people don't have to put up with this, but there are some with older 
televisions that do. When I got the PS3 I had to start it up on the colorstream 
inputs, tell it that I can use 480p/1080i, swap the connector over to the HD 
ports, change the tv input with the remote, and click OK to confirm it works, 
so that I can use it on HD ports.

Holding the button down for 5 seconds and letting it reset the boot flag, and 
also the video, will mean I get to go through that whole mess each time. It's 
already bad enough I can't see any of kboot's output, or anything else, until 
the video=480p option kicks in.

Glad to hear that the support is coming though, and it is appreciated. I'll 
definitely be installing F8 Test releases to try and help catch any of the 
problems before it gets released.

Comment 8 Patrick Clément-Bonhomme 2007-08-01 16:04:56 EDT
The newest kernel (kernel-2.6.22.1-41.fc7) solved the original issue. Didn't
test "boot-game-os" though as I am working remotely on the PS3 (and the console
isn't used for gaming!).

Comment 9 Bill Blake 2007-08-02 12:38:44 EDT
See this thread on fedoraforum regarding fixing the boot-game-os command and
rebooting without using the power button:

http://forums.fedoraforum.org/showpost.php?p=840325&postcount=13

Note You need to log in before you can comment on or make changes to this bug.