This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 249219 - Running firefox in KDE is different when running from the ALT-F2 prompt and from konsole
Running firefox in KDE is different when running from the ALT-F2 prompt and f...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
FF3RawhideClose
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-22 19:41 EDT by Dorin Lazar
Modified: 2007-12-20 11:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:47:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dorin Lazar 2007-07-22 19:41:09 EDT
Description of problem:
Running firefox in KDE is different when running from the ALT-F2 prompt and from
konsole

Version-Release number of selected component (if applicable):
2.0.0.5-2.fc8

How reproducible:
always

Steps to Reproduce:
1. Press ALT-F2 while in KDE
2. type firefox, ENTER
3. Firefox starts with a different color scheme than the one used in KDE
4. Press ALT-F2, run konsole
5. type firefox, ENTER
6. Firefox starts with the color scheme selected in KDE

Actual results:
The colors scheme is selected differently when ran from konsole and run from the
ALT-F2 prompt

Expected results:
The color scheme should be the one currently set in KDE.

Additional info:
   I have different results when running firefox in KDE in two ways. One is by
pressing ALT-F2 and typing firefox (or /usr/bin/firefox) - and firefox doesn't
get the color theme currently used in KDE and when ran from konsole (BUT NOT
xterm) the KDE color theme is correctly applied. Also, if ran from the ALT-F2
(Run command) prompt, even if selected 'start in terminal', firefox doesn't have
the current color theme applied.
  This is the rawhide with the latest updates. to have 'KDE' running I have done
a yum groupremove GNOME, yum groupinstall KDE (perhaps there is some package
incorrectly removed with this procedure?
Comment 1 Matěj Cepl 2007-12-20 11:47:52 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays

Note You need to log in before you can comment on or make changes to this bug.