Bug 249221 - Package Manager installs packages without installing the dependencies, leaving packages install unfunctional
Package Manager installs packages without installing the dependencies, leavin...
Status: CLOSED DUPLICATE of bug 242368
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-07-22 20:58 EDT by Rodd Clarkson
Modified: 2014-01-21 17:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-23 07:08:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2007-07-22 20:58:24 EDT
Description of problem:

It is possible to install packages with the package manager without the required
dependencies being installed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Click Applications > Add/Remove Software
2. In the Browse Tab, Select Applications, Games and Entertainment and then
Click Optional Packages
3. Select a package with requirements.  (I'm using 'asc'.  I've also had this
problem with FlightGear and reproduced it with abuse.)  Having selected a
package, click Close.
4. Click Apply in the main window.
5. Click Continue in the Package Selections Dialog
6. You should get a dependencies added dialog.  Click Cancel
7. Now, click Apply again in the main window.
8. Click Continue in the Package Selections Dialog (again).

Actual results:

Package manager downloads and installs only the package selected and not the
dependencies.  It also doesn't ask if you want to install the dependencies the
second time around.

Expected results:

The package manager shouldn't be able to install a package without installing
dependencies.  It should prompt each time you try to install packages
Comment 1 Mike Chambers 2007-07-22 23:23:56 EDT
I tested the problem above,and I as well ran into the same thing.  It seems
pirut/yum/whatever shows the dependencies, but after canceling and applying
again, it thinks it's met them when it really didn't.  It *should* have done the
same dependency list again and not let anything happen until that is met.
Comment 2 Mike Chambers 2007-07-22 23:38:22 EDT
I tested using yum itself and got the depends, but it wouldn't install by
itself, or at least didn't see a way/test to do it.  So must be on pirut end, or
along those lines that is causing it.
Comment 3 Florian Festi 2007-07-23 07:08:30 EDT

*** This bug has been marked as a duplicate of 242368 ***

Note You need to log in before you can comment on or make changes to this bug.