Bug 249222 - kernel 2.6.22 corrupts console output during boot (Apple Powerbook 12", GeForce FX 5200)
Summary: kernel 2.6.22 corrupts console output during boot (Apple Powerbook 12", GeFor...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: powerpc Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-23 01:37 UTC by Alex Kanavin
Modified: 2007-12-08 01:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-08 01:11:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a photo of the screen with corrupted output (135.20 KB, image/jpeg)
2007-07-23 01:37 UTC, Alex Kanavin
no flags Details

Description Alex Kanavin 2007-07-23 01:37:43 UTC
Description of problem:
on my powerbook 12" with GeForce FX 5200 during the boot sequence the console output is corrupted 
so that it's totally unreadable. Using video=ofonly option fixes the problem. Also, it only happens when 
using an external display.

Version-Release number of selected component (if applicable):
2.6.22.1 kernel update
2.6.21 worked fine

How reproducible:
every time during boot

Steps to Reproduce:
1. Start booting the system
2. Watch the output

Comment 1 Alex Kanavin 2007-07-23 01:37:43 UTC
Created attachment 159756 [details]
a photo of the screen with corrupted output

Comment 2 Alex Kanavin 2007-08-04 02:01:12 UTC
The problem persists with latest kernels 2.6.23-0.61.rc1.git9.fc8 and
2.6.22.1-41.fc7

Comment 3 Chuck Ebbert 2007-08-06 15:37:29 UTC
Does the GUI work okay once it gets past bootup?



Comment 4 Alex Kanavin 2007-08-06 15:43:21 UTC
Yes, it works well. I think there are problems if you switch from GUI to the
console and back, but if you stay in the GUI, it works fine.

Comment 5 Christopher Brown 2007-09-20 11:05:31 UTC
Hello Alex,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris

Comment 6 Alex Kanavin 2007-09-20 11:21:10 UTC
Hi Chris,

I've taken the issue to the kernel framebuffer maintainer, and we have
identified the patch that caused the regression. He has just produced another
patch to reverse the original one:
http://sourceforge.net/mailarchive/forum.php?thread_name=46EB2077.2060004%40gmail.com&forum_name=linux-fbdev-devel
so when it makes its way to the kernel, and from there to Fedora repo, the
problem should be gone. I'll be happy to close the bug then :)

Comment 7 Alex Kanavin 2007-12-08 01:11:26 UTC
2.6.24 kernels have the fix included - the problem is fixed in rawhide


Note You need to log in before you can comment on or make changes to this bug.