Bug 249249 - Usage of an USB scanner as non root user in F7 unpossible
Usage of an USB scanner as non root user in F7 unpossible
Status: CLOSED DUPLICATE of bug 244444
Product: Fedora
Classification: Fedora
Component: xsane (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-23 06:08 EDT by Joachim Backes
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 06:39:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2007-07-23 06:08:02 EDT
Description of problem:
having an USB scanner of type Canon Lide 30.  As root, the usage of this scanner
with xsane makes no problems, but the usage of xsane as non root user says: ne
devices found.

Version-Release number of selected component (if applicable):
xsane-0.994-3.fc7
kernel-2.6.22.1-27.fc7

How reproducible:
each time

Steps to Reproduce:
1.start xsane with UID not 0
2.
3.
  
Actual results:
no devices found

Expected results:
xsane start correctly

Additional info:
Running sane-find-scanner as non root user:
============================================

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9, product=0x220e, chip=LM983x?) at libusb:002:004
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.

lsusb:
=====
lsusb
Bus 003 Device 003: ID 0dbf:9001 Quik Tech Solutions
Bus 003 Device 002: ID 0ecd:a100 Lite-On IT Corp.
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 004: ID 04a9:220e Canon, Inc. CanoScan N1240U/LiDE 30
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 05fe:0011 Chic Technology Corp. Browser Mouse
Bus 001 Device 001: ID 0000:0000

Section from /proc/bus/usb/devices:
===================================
T:  Bus=02 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#=  4 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=ff(vend.) Sub=00 Prot=ff MxPS= 8 #Cfgs=  1
P:  Vendor=04a9 ProdID=220e Rev= 1.00
S:  Manufacturer=Canon
S:  Product=CanoScan
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=ff Driver=(none)
E:  Ad=81(I) Atr=03(Int.) MxPS=   1 Ivl=16ms
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
Comment 1 Nils Philippsen 2007-07-23 06:39:20 EDT

*** This bug has been marked as a duplicate of 244444 ***

Note You need to log in before you can comment on or make changes to this bug.