Bug 249299 - RFE: option to ignore global excludes
Summary: RFE: option to ignore global excludes
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-23 15:48 UTC by Ian Collier
Modified: 2014-01-21 22:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 18:47:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Collier 2007-07-23 15:48:38 UTC
If I want to avoid accidentally updating something at the wrong time (say, a
kernel module which needs a newer kernel) I may place a global exclusion in
/etc/yum.conf.  However, there doesn't now seem to be a way of deliberately
updating this thing without re-editing yum.conf.  "yum list" also won't even
tell me that a new version of it is available.

What I propose is one or more of the following:

* an option "--include=xxx" which can override previously specified excludes;
* an option "--noexclude" which just ignores all previously specified excludes;
* if I name the package exactly on the command line then don't exclude it,
despite what the global excludes say (perhaps this should only apply to "yum list").

For now I suppose "yum -c /dev/null" or "yum -c /etc/yum.conf.noexclude" would
work, but it's less convenient if you ever actually edit your yum configuration
since you then have to keep two files in step with each other.

Comment 1 Jeremy Katz 2007-09-13 18:47:38 UTC
This isn't something that I really see as a common request.  If you really want
it, you could easily implement it as a plugin.  But it's not something that
we're going to do for the yum core.


Note You need to log in before you can comment on or make changes to this bug.