Bug 249340 - Kernel 2.6.22.1-27.fc7 fails to find PCI sound card
Kernel 2.6.22.1-27.fc7 fails to find PCI sound card
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-23 15:59 EDT by Mark Eggers
Modified: 2008-01-09 12:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 12:12:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from 2.6.22.1-27.fc7 kernel (20.43 KB, text/plain)
2007-07-23 15:59 EDT, Mark Eggers
no flags Details
dmesg output without pci=routeiq (17.05 KB, text/plain)
2007-07-27 16:33 EDT, Mark Eggers
no flags Details
dmesg output with pci=routeirq kernel 2.6.22.1-33.fc7 (17.62 KB, text/plain)
2007-07-27 16:34 EDT, Mark Eggers
no flags Details
dmseg from pci=nomsi,nommconf and kernel 2.6.22.1-41.fc7 (24.39 KB, text/plain)
2007-08-10 18:57 EDT, Mark Eggers
no flags Details
Current modprobe.conf (195 bytes, text/plain)
2007-08-13 15:30 EDT, Mark Eggers
no flags Details
Original modprobe.conf (135 bytes, text/plain)
2007-08-13 15:32 EDT, Mark Eggers
no flags Details

  None (edit)
Description Mark Eggers 2007-07-23 15:59:24 EDT
Description of problem:
Booting 2.6.22.1-27.fc7 fails to load Santa Cruz Turtle Beach sound card.  This
was successful in the previous kernel (2.6.21-1.3228.fc7).

Version-Release number of selected component (if applicable):
Kernel 2.6.22.1-27.fc7

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel 2.6.22.1-27.fc7
  
Actual results:
No sound.  dmesg includes the following  lines:

cannot find the slot for index 0 (range 0-7), error: -16
Sound Fusion CS46xx: probe of 0000:02:0a.0 failed with error -12

Expected results:
dmesg from 2.6.21-1.3228.fc7

gameport: CS46xx Gameport is pci0000:02:0a.0/gameport0, speed 1147kHz


Additional info:
No Sound Fusion information shows up in the earlier kernel.

Hardware information follows:

Dell Dimension 8200
 General Information :	 
NorthBridge :	Intel i850E 
SouthBridge :	82801BA (ICH2) LPC Interface Controller 

 NorthBridge Information :	 
Architecture :	HUB 
Manufacturer :	Intel (Dell Computer Corp) 
Codename :	Tehama 
Revision :	A3 
Bus Speed :	99.7 MHz 
FSB Frequency :	398.8 MHz (QDR) 

 Memory Information :	 
Type :	RDRAM PC1073741824 
Frequency :	398.8 MHz 
DRAM/FSB Ratio :	1/1 
Supported Channels :	Dual  (128-bit) 
Activated Channels :	Dual 
ECC Diagnostic :	No 
Total CAS# (tRDRAM) :	10 clocks 
Row To Column (tRCD) :	7 clocks 

 Bus Information :	 
Version :	2.0 
Transfert Rate supported :	1x, 2x, 4x 
Transfert Rate :	4x 
Aperture Size :	256 MB 
Side Band supported :	Yes 
Side Band enabled :	Yes 
AGP enabled :	Yes 

 APIC Information :	 
Version :	2.00 
Maximum Interrupts :	24 
IRQ Handler enabled :	Yes 

 Hub Interface Information :	 
Version :	1.00 
Time Slice :	0 
Width :	8-bit 
Full Duplex :	Yes 
Frequency :	4x  (264 MHz) 
Multiplier :	1/1x 

 Device Capabilities (PCI) :	 
I/O Access :	No 
Memory Access :	Yes 
Bus Master Capable :	Yes 
Special Cycle Recognition :	No 
Memory Write & Invalidate :	No 
VGA Palette Snoop :	No 
Parity Error Response :	No 
Cycle Wait :	No 
System Error Line :	Yes 
Fast Back-to-Back :	No 
Detects Parity Errors :	No 
User Defined Format :	No 
PCI 66Mhz Bus Support :	No 
New Capability List :	Yes 
PCI Support :	AGP 

PCI Information:
 General Information :	 
Number of PCI Bus :	3 
Number of PCI Connectors :	4 

 Peripheral Type :	 
Device 1, Bus 0 :	AGP 
Device 1, Bus 1 :	AGP 

 General Features :	 
Support Mechanism 1 :	Yes 
Support Mechanism 2 :	No 

 Bus Information #0 :	 
Device :	82850/E Host-Hub Interface Bridge Device 
Device :	82850/E/860 AGP Bridge 
Device :	82801BA/CA/DB/DBL/EB/ER/FB/GB (ICH2/3/4/4/5/5/6/7), 6300ESB Hub
Interface to PCI Bridge 
Device :	82801BA (ICH2) LPC Interface Controller 
Device :	82801BA (ICH2) UltraATA/100 IDE Controller 
Device :	82801BA/BAM (ICH2/ICH2-M) USB Universal Host Controller 
Device :	82801BA/BAM (ICH2/ICH2-M) SMBus Controller 
Device :	82801BA/BAM (ICH2/ICH2-M) USB Universal Host Controller 
Device :	82801BA/BAM (ICH2/ICH2-M) AC'97 Audio Controller 

 Bus Information #1 :	 
Device :	GeForce FX 5700LE [NV36.3] 

 Bus Information #2 :	 
Device :	SoftK56 Speakerphone Winmodem 
Device :	82550/1/7/8/9 EtherExpress PRO/100(B) Ethernet Adapter 
Device :	Crystal CS4610/14/22/24/30 SoundFusion PCI Audio Accelerator
Comment 1 Mark Eggers 2007-07-23 15:59:24 EDT
Created attachment 159811 [details]
dmesg from 2.6.22.1-27.fc7 kernel
Comment 2 Mark Eggers 2007-07-27 16:33:12 EDT
Created attachment 160138 [details]
dmesg output without pci=routeiq

New kernel - same issue
Comment 3 Mark Eggers 2007-07-27 16:34:52 EDT
Created attachment 160139 [details]
dmesg output with pci=routeirq kernel 2.6.22.1-33.fc7

This is with pci=routeirq.  The same problem occurs.
Comment 4 Mark Eggers 2007-08-01 00:22:58 EDT
Problem still exists in new kernel 2.6.22.1-41
Comment 5 Mark Eggers 2007-08-01 01:22:49 EDT
Have tried booting 2.4.22.1-41 with the following options to no effect:

pci=bios
pci=nobios
pci=norouteirq

All fail in exactly the same way.
Comment 6 Mark Eggers 2007-08-01 17:09:20 EDT
Upgraded to the following from updates-testing:

udev-113-8.fc7

Still the same problem with the following error messages and no sound on an
external (PCI) sound card:

snd_seq_midi_event: Unknown symbol snd_seq_expand_var_event
ACPI: PCI Interrupt 0000:00:1f.5[B] -> GSI 17 (level, low) -> IRQ 18
PCI: Setting latency timer of device 0000:00:1f.5 to 64
usbcore: registered new interface driver snd-usb-audio
intel8x0_measure_ac97_clock: measured 50213 usecs
intel8x0: clocking to 41142
cannot find the slot for index 0 (range 0-7), error: -16
Sound Fusion CS46xx: probe of 0000:02:0a.0 failed with error -12
No dock devices found.
Comment 7 Mark Eggers 2007-08-09 20:01:25 EDT
Problem continues with exactly the same dmesg report with udev-113-9.fc7 and
kernel 2.6.22.1-41.fc7.  System continues to work as expected with
udev-113-9.fcy and kernel 2.6.21-1.3228.  2.6.21-1.3228 is the last kernel that
works on this hardware.
Comment 8 Chuck Ebbert 2007-08-10 17:02:11 EDT
Please try booting with "pci=nomsi,nommconf"
Comment 9 Mark Eggers 2007-08-10 18:57:46 EDT
Created attachment 161101 [details]
dmseg from pci=nomsi,nommconf and kernel 2.6.22.1-41.fc7
Comment 10 Chuck Ebbert 2007-08-13 15:12:27 EDT
(In reply to comment #6)
> cannot find the slot for index 0 (range 0-7), error: -16

What is in /etc/modprobe.conf? (Just post the whole file.)
Comment 11 Mark Eggers 2007-08-13 15:28:02 EDT
Interesting in that the /etc/modprobe.conf before 4/6 shows no sign of the
onboard Intel sound card, which it shouldn't since it's disabled in the bios. 
However, the current /etc/modprobe.conf shows the onboard Intel sound card.
Comment 12 Mark Eggers 2007-08-13 15:30:35 EDT
Created attachment 161210 [details]
Current modprobe.conf

This is the current modprobe.conf file.  It has both the Intel sound card and
the PCI (TurtleBeach) sound card listed.
Comment 13 Mark Eggers 2007-08-13 15:32:42 EDT
Created attachment 161212 [details]
Original modprobe.conf

This is the modprobe.conf file that was created during the original
installation of F7 on this machine.  Note that it does not have the onboard
Intel sound card.
Comment 14 Chuck Ebbert 2007-08-13 16:12:49 EDT
Try swapping the two entries in modprobe.conf by changing all the "-1" to "-0"
and all the "-0" to "-1". (This will put the intel driver in index 0.)
Comment 15 Mark Eggers 2007-08-13 17:36:36 EDT
This appears to have enabled sound.  However, this breaks sound on the previous
kernel (2.6.21 series(.  I verified operation on the latest kernel by booting
into init=3. then running mplayer to play an mp3 file.

Interestingly, when I opened alsamixer, it reported my usb camera (which has a
microphone) as sound card 0.  This could be causing the confusion, since that
sound card does not appear in modprobe.conf, nor does it appear the the Gnome
menu for sound configuration.

Are there lines I should add in modprobe.conf to account for the webcam microphone?
Comment 16 Christopher Brown 2007-09-20 07:13:48 EDT
Hello Mark,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel? If so, it might be helpful
to run lsusb -v (you may have to install usbutils) and attach the output to this
bug. 

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 17 Christopher Brown 2008-01-09 12:12:21 EST
As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

Note You need to log in before you can comment on or make changes to this bug.