Bug 249343 - w3m crashes immediately
w3m crashes immediately
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: w3m (Show other bugs)
rawhide
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-07-23 16:18 EDT by Tomas Mraz
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version: w3m-0.5.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 08:17:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Mraz 2007-07-23 16:18:14 EDT
w3m crashes on x86_64 immediately with segfault. I don't know whether it crashes
on other architectures as well.

The crash is in gc library so I'm cc-ing gc library maintainer.


0x00002aaaaaaf2ec9 in GC_malloc (bytes=24) at thread_local_alloc.c:176
176         GC_FAST_MALLOC_GRANS(result, granules, tiny_fl, DIRECT_GRANULES,
(gdb) bt
#0  0x00002aaaaaaf2ec9 in GC_malloc (bytes=24) at thread_local_alloc.c:176
#1  0x000000000045ccbe in newGeneralList () at textlist.c:23
#2  0x000000000040fcd3 in main (argc=1, argv=0x7fff0ced58b8, 
    envp=<value optimized out>) at main.c:408
#3  0x0000003b51a1daa4 in __libc_start_main () from /lib64/libc.so.6
#4  0x00000000004045d9 in _start ()
Comment 1 Jens Petersen 2007-07-24 00:54:50 EDT
Reproduced with current packages in development.
(Doesn't happen with f7 x86_64 for me.)

Could you try reverting to gc-6.8 to see if that makes a difference?
Comment 2 Tomas Mraz 2007-07-24 05:24:58 EDT
Yes, reverting gc to 6.8 helps. And rebuilding w3m against gc-7.0 helps too. So
that means ABI break in gc. So all dependencies of gc should be rebuilt. 

[root@rawhide64 ~]#  repoquery --whatrequires 'libgc.so.1()(64bit)'
gc-0:7.0-1.fc8.x86_64
sdcc-0:2.6.0-10.fc7.x86_64
Macaulay2-0:0.9.95-4.fc7.x86_64
asymptote-0:1.32-1.fc8.x86_64
gc-devel-0:7.0-1.fc8.x86_64
inkscape-0:0.45.1-1.fc7.x86_64
w3m-0:0.5.2-1.fc8.x86_64
Comment 3 Tomas Mraz 2007-07-24 05:28:48 EDT
Ccing owners of the above packages.
Comment 4 Denis Leroy 2007-07-24 05:34:05 EDT
I would prefer if gc were held back to 6.8, since it's only in updates-testing.
This is a gc bug after all, it's not meant to break ABI. Looking at the gc
mailing list, there seems to be a number of issues with 7.0, i.e. ABI could
break again with further 7.x updates.
Comment 5 Tomas Mraz 2007-07-24 05:36:56 EDT
(In reply to comment #4)
> I would prefer if gc were held back to 6.8, since it's only in updates-testing.
> This is a gc bug after all, it's not meant to break ABI. Looking at the gc
> mailing list, there seems to be a number of issues with 7.0, i.e. ABI could
> break again with further 7.x updates.
> 

For Fedora 7 that's clear - there should be no ABI breaking update. But for
Fedora 8 I'd leave that on the gc maintainer. Rex?
Comment 6 Parag Nemade 2007-07-24 05:38:50 EDT
on Tomas Mraz request, I already started w3m build on koji for devel branch.
Comment 7 Denis Leroy 2007-07-24 05:41:41 EDT
See also

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=248700
Comment 8 Parag Nemade 2007-07-24 05:47:10 EDT
w3m-0.5.2-2 built successfully against gc-7.0
Comment 9 Denis Leroy 2007-07-24 07:19:15 EDT
Reopening for F-7. I submitted a patch to work around this for bug 248700.
Comment 10 Parag Nemade 2007-07-24 07:22:00 EDT
will wait for new release of gc for F7 and then accordingly release new version
of w3m for F7 only.
Comment 11 Tomas Mraz 2007-07-24 08:17:28 EDT
I think that for F7 the gc should be fixed which is the bug 248700.

So no need for reopening this one.

(IMHO gc should be fixed for F8 - rawhide too.)

Note You need to log in before you can comment on or make changes to this bug.