Bug 249383 - Kernel 2.6.22.1-27.fc7 can't see sata drive
Summary: Kernel 2.6.22.1-27.fc7 can't see sata drive
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-24 07:52 UTC by Ian Kent
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 2.6.22.1-41.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 13:59:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output from working system (25.60 KB, text/plain)
2007-07-24 07:52 UTC, Ian Kent
no flags Details
lspci output from working system (2.16 KB, text/plain)
2007-07-24 07:53 UTC, Ian Kent
no flags Details
Photo #1 of SATA init fail at boot (60.85 KB, image/png)
2007-07-24 07:54 UTC, Ian Kent
no flags Details
Photo #2 of SATA init fail at boot (62.97 KB, image/png)
2007-07-24 07:57 UTC, Ian Kent
no flags Details

Description Ian Kent 2007-07-24 07:52:04 UTC
Description of problem:
Looks like the kernel fails to initialize SATA driver at boot.

Version-Release number of selected component (if applicable):
kernel-2.6.22.1-27.fc7

How reproducible:
Always

Steps to Reproduce:
Happens when booting system.
  
Actual results:
See screen shots.

Expected results:
Works OK.

Additional info:
See dmesg and lspci output from working system.

Comment 1 Ian Kent 2007-07-24 07:52:05 UTC
Created attachment 159838 [details]
dmesg output from working system

Comment 2 Ian Kent 2007-07-24 07:53:23 UTC
Created attachment 159839 [details]
lspci output from working system

Comment 3 Ian Kent 2007-07-24 07:54:52 UTC
Created attachment 159840 [details]
Photo #1 of SATA init fail at boot

Comment 4 Ian Kent 2007-07-24 07:57:29 UTC
Created attachment 159841 [details]
Photo #2 of SATA init fail at boot

This is not to clear but I was in a hurry as it
disappears fairly quickly. Hopefully you will be
able to make sense from the two photos.

Comment 5 Vaclav "sHINOBI" Misek 2007-08-08 11:57:24 UTC
This bug seems to be the same as #232897 but with different chipset.

Comment 6 Ian Kent 2007-08-08 12:07:10 UTC
(In reply to comment #5)
> This bug seems to be the same as #232897 but with different chipset.

And probably the same as in bug 249469.
Adding the options given in comment #9 seems to have resolved the
problem for me but that doesn't change the fact that something
isn't quite right.

Ian


Comment 7 Chuck Ebbert 2007-08-08 17:19:50 UTC
We probably need to go back to disabling MSI by default.

Comment 8 Vaclav "sHINOBI" Misek 2007-08-09 06:00:22 UTC
Just for curiosity. Are these problems due to the wrong MSI implementation in
kernel or due to its implementation in various devices?

Comment 9 Chuck Ebbert 2007-08-09 15:58:46 UTC
(In reply to comment #8)
> Just for curiosity. Are these problems due to the wrong MSI implementation in
> kernel or due to its implementation in various devices?

MSI was broken in previous kernels but should be fixed now. There are devices
that don't work right and there are also motherboards that are broken (BIOS
updates sometimes fix those.)


Comment 10 Christopher Brown 2007-09-20 11:16:14 UTC
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris

Comment 11 Ian Kent 2007-09-20 13:59:15 UTC
(In reply to comment #10)
> There hasn't been much activity on this bug for a while. Could you tell me if
> you are still having problems with the latest kernel?

It has been fixed in a later kernel.
I'm running 2.6.22.1-41.fc7 at the moment.
Thanks
Ian


Comment 12 Christopher Brown 2007-09-20 14:13:55 UTC
Thanks for the update Ian. I'm adjusting the resolution to let folks know what
worked for them.

Cheers
Chris


Note You need to log in before you can comment on or make changes to this bug.