Bug 249384 - gcc-4.1.2-16 will require binutils-2.17.50.0.17-3
Summary: gcc-4.1.2-16 will require binutils-2.17.50.0.17-3
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-24 08:12 UTC by Oliver Falk
Modified: 2008-01-11 17:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 07:24:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oliver Falk 2007-07-24 08:12:06 UTC
Please fix in your BuildReqs...

Comment 1 Jakub Jelinek 2007-07-24 08:18:09 UTC
Care to explain what's wrong?
grep binutils-2.17.50 gcc41.spec; koji latest-pkg dist-f8 gcc binutils
BuildRequires: binutils >= binutils-2.17.50.0.17-3
Requires: binutils >= binutils-2.17.50.0.17-3
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
gcc-4.1.2-16                              dist-f8               jakub
binutils-2.17.50.0.17-3                   dist-f8               roland


Comment 2 Oliver Falk 2007-07-24 09:05:36 UTC
Arg. Yes, sorry Jakub, doesn't seem to be your fault... But who's fault is it.
Have a look at this:

[oliver@gosa gcc]$ grep "BuildRequires:.*binutils" *.spec
BuildRequires: binutils >= binutils-2.17.50.0.17-3
[oliver@gosa gcc]$ rpm -q binutils
binutils-2.17.50.0.17-1
[oliver@gosa gcc]$ make alpha
rpmbuild --define "_sourcedir /home/oliver/cvs/devel/gcc" --define "_builddir
/home/oliver/cvs/devel/gcc" --define "_srcrpmdir /home/oliver/cvs/devel/gcc"
--define "_rpmdir /home/oliver/cvs/devel/gcc" --define "dist .fc8" --define
"fedora 8" --target alpha -ba gcc41.spec 2>&1 | tee .build-4.1.2-16.log
Building target platforms: alpha
Building for target alpha
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.39127
+ umask 022
+ cd /home/oliver/cvs/devel/gcc
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /home/oliver/cvs/devel/gcc
+ rm -rf gcc-4.1.2-20070723
[ ... ]


Duh!?

Sorry Jakub for bugging you; I didn't have a look at the spec - I saw a new gcc
build yesterday and just did >make alpha< and somewhere it crashed because my
binutils are too old. But I wonder RPM didn't catch that BuildReq...

Comment 3 Oliver Falk 2007-07-24 09:11:39 UTC
OK. Tried that on i386 box as well:
[oliver@tuborg gcc]$ grep "BuildRequires.*binutils" *.spec
BuildRequires: binutils >= binutils-2.17.50.0.17-3
[oliver@tuborg gcc]$ rpm -q binutils
binutils-2.17.50.0.12-4
[oliver@tuborg gcc]$ make i386
rpmbuild --define "_sourcedir /home/oliver/cvs/Fedora/devel/gcc" --define
"_builddir /home/oliver/cvs/Fedora/devel/gcc" --define "_srcrpmdir
/home/oliver/cvs/Fedora/devel/gcc" --define "_rpmdir
/home/oliver/cvs/Fedora/devel/gcc" --define "dist .fc8" --define "fedora 8"
--target i386 -ba gcc41.spec 2>&1 | tee .build-4.1.2-16.log
error: Failed build dependencies:
        dejagnu is needed by gcc-4.1.2-16.i386
        bison is needed by gcc-4.1.2-16.i386
        texinfo is needed by gcc-4.1.2-16.i386
        gcc-gnat >= 3.1 is needed by gcc-4.1.2-16.i386
        libgnat >= 3.1 is needed by gcc-4.1.2-16.i386
        firefox-devel is needed by gcc-4.1.2-16.i386
        libXtst-devel is needed by gcc-4.1.2-16.i386
        libXt-devel is needed by gcc-4.1.2-16.i386
Building target platforms: i386
Building for target i386


I'm missing some deps as you can see, but it doesn't list binutils. What's wrong!?

Comment 4 Oliver Falk 2007-07-24 09:13:05 UTC
Added rpm pkg maintainer: pnasrat@redhat.com. Maybe he knows....

Comment 5 Oliver Falk 2007-07-24 09:49:55 UTC
OK. Next problem. Jakub that's for you. Rebuilt binutils-2.17.50.0.17-3 on alpha
and now I get the following:
configure:3194: $? = 1
configure:3217: checking for C compiler default output file name
configure:3244: gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
--param=ssp-buffer
-size=4 -mieee   conftest.c  >&5
{standard input}: Assembler messages:
{standard input}:170: Fatal error: can't close /tmp/ccxoVVJ6.o: Bad file descriptor


For everything that I try to compile :-(

Comment 6 Paul Nasrat 2007-07-24 10:14:15 UTC
binutils >= binutils-2.17.50.0.17-3
should be
binutils >= 2.17.50.0.17-3

Comment 7 Oliver Falk 2007-07-24 10:40:12 UTC
Well. What a stupid mistake. :-) And nobody of us saw it. Thx Paul! I knew
you'll find some good answer, but that it will be such a simple one, I didn't
expect.

Jakub, can you fix in cvs please and have a look at comment #5.

Comment 8 Jakub Jelinek 2007-07-24 13:31:27 UTC
Thanks Paul, will fix.
Regarding the as error, there were no changes in gas at all between -1 and -3,
so if -1 worked, then something else had to change in your environment.
You can try strace to see where it fails, gdb it, ...
It certainly works here.

Comment 9 Jakub Jelinek 2007-07-25 07:24:38 UTC
Should be fixed in gcc-4.1.2-17.


Note You need to log in before you can comment on or make changes to this bug.