Bug 249399 - inability to install to PATA HD with >15 partitions not addressed
inability to install to PATA HD with >15 partitions not addressed
Status: CLOSED RAWHIDE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: Paul W. Frields
Paul W. Frields
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-24 09:18 EDT by Felix Miata
Modified: 2007-09-15 10:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-15 10:24:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Miata 2007-07-24 09:18:00 EDT
Since legacy storage drivers were replaced by libata the SCSI limit of 15
partitions per HD applies to PATA devices formerly permitted up to 63 partitions
per HD. This prevents F7 upgrades of previous versions installed to /dev/hda16
or above, and to previous versions installed to /dev/hda15 or below on HDs on
which more than 15 partitions exist and cannot be permitted to be reduced to 15
or less by Anaconda's partitioning step. None of 
http://docs.fedoraproject.org/install-guide/f7/en_US/ or
http://fedoraproject.org/wiki/DistributionUpgrades or 
http://docs.fedoraproject.org/release-notes/f7/ directly address the problem or
suggest how to deal with it.
Comment 1 157bug 2007-08-29 00:46:56 EDT
It does appear that the Fedora team do not wish to address this, either to say
FO or that it is an issue.
Comment 2 Paul W. Frields 2007-08-30 13:00:44 EDT
I've added a note at http://fedoraproject.org/wiki/YumUpgradeFaq that addresses
this problem, but I'm fairly certain this is a corner case.  In addition, for
some time now Fedora has been using and recommending LVM, since it allows the
system owner to sidestep these kinds of problems fairly easily.
Comment 3 Felix Miata 2007-08-30 15:21:02 EDT
(In reply to comment #2)
>for some time now Fedora has been using and recommending LVM, since it allows
>the system owner to sidestep these kinds of problems fairly easily.

That's a perfectly fine recommendation only for those using Fedora 7
exclusively. It stinks when the system is multiboot with non-Linux OS
installations as well as legacy Linux installations, any or all of which may be
incompatible with Linux LVM.

FYI, both SUSE and Mandriva in current release and development versions permit
access to all PATA partitions, regardless of number.
Comment 4 Paul W. Frields 2007-08-30 17:07:20 EDT
Other distributions may not be carrying the new libata stack as Fedora does,
which emulates PATA drives as SCSI.  All SCSI drives have been limited in the
kernel to 15 partitions throughout the 2.6 branch (and possibly before), and
patching that behavior is not something I think kernel devs are going to want to
do, since it would require fairly extensive changes.  Furthermore, LVM use isn't
limited to Fedora 7; it's been in Fedora for quite a long time, and support for
LVM is in most other mainline distros.  Linux LVM support is also available for
other operating systems such as Windows.
Comment 5 Felix Miata 2007-08-30 18:16:54 EDT
SCSI has always been subject to the 15 partition limit. It's only a relatively
recent kernel architecture change that imposed SCSI's 15 partition upon PATA in
place of its traditional limit of 63.

This bug is about documenting how to do what's possible to do in Fedora now, not
whether what it is doing is right or wrong or the same or not as its competition.

Right now, that one line on http://fedoraproject.org/wiki/YumUpgradeFaq that
says "IDE hard disks with more than 15 partitions are not supported in Fedora
7." is the only apparent doc reference anywhere to the effect that upgrading to
or installing F7 on systems with >15 PATA partitions is impossible. If that's
all there is, it isn't enough. It's a minimalist and inadequate way of saying,
sorry, you'll need to switch to a competing distro or use FC6  or add another HD
if you want to preserve access to and/or leave undisturbed your existing legacy
partitioning. Official docs, including the README and Installation Guide, need
to address the issue also.

This limitation does not exist in current and next versions of major distros
Mandriva and SUSE, even though both in latest incarnations do use the same basic
libata SCSI emulation system as Fedora. Each simply provides some optional means
to not load libata and instead load an appropriate legacy IDE driver. IIRC, this
also applied at least recently to current Debian and *buntu 7.04 (I haven't
tested those 2 in several months).

SUSE is apparently on the verge of a solution that extends access to up to 63
partitions to SATA as well as to PATA:
https://bugzilla.novell.com/show_bug.cgi?id=218122
Comment 6 Paul W. Frields 2007-09-15 10:24:25 EDT
I've added a section in the release notes for F8 to cover this as well.  If
you're interested in seeing a change in the functionality, please open a new bug
against e.g. mkinitrd.

Note You need to log in before you can comment on or make changes to this bug.