Bug 249435 - ldconfig borked against 32-bit libraries
Summary: ldconfig borked against 32-bit libraries
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: F8Test1
TreeView+ depends on / blocked
 
Reported: 2007-07-24 17:35 UTC by Valdis Kletnieks
Modified: 2013-01-10 04:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 19:48:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Valdis Kletnieks 2007-07-24 17:35:24 UTC
Description of problem:
ldconfig prints multiple messages of the form:

ldconfig: file /usr/lib/libgomp.so.1 is truncated

and then fails to build symlinks for those libraries.  Only 32-bit libraries
seem to be affected from this morning's yum update (32-bit libraries from
yesterday's update seem to be OK).  This is likely related to gcc-4.1.2-16
update today.  RPMs affected include gtk2, libgcc, libgcj, libgomp, libstdc++,
metacity, and possibly others (I don't have a full 32-bit environment on this
system, so yum may not have attempted updating other non-installed 32-bit RPMs).

Version-Release number of selected component (if applicable):
glibc-2.6-4

How reproducible:
Running /sbin/ldconfig after updating to 2007-07-24 rawhide

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Examining the glibc-20070515T2025/elf/readelf.c source, the problem appears to
be that gcc is now generating something that is giving the check_ptr() macro
indigestion.  Unfortunately, I can't tell which of the 7 check_ptr() in
readelf.c is complaining, or why....

Comment 1 Jakub Jelinek 2007-07-25 07:38:19 UTC
Bug in binutils, should be fixed now in binutils-2.17.50.0.17-5 and
the gcc libs in gcc-4.1.2-17.  gtk2, metacity, possibly others need rebuild
though.

Comment 2 Jesse Keating 2007-07-25 14:06:13 UTC
I'm re-opening this bug until we get the packages rebuilt that were built during
this time, and attaching it to the F8 Test1 tracker.

Comment 3 Jesse Keating 2007-07-25 16:56:37 UTC
A list of packages to rebuild is at http://jkeating.fedorapeople.org/needrebuild

I'll be working through them.

Comment 4 Jesse Keating 2007-07-25 19:48:10 UTC
And now they're all rebuild (except for obvious not neededs like kernel-xen and
x11-xorg-proto-devel) and tagged for F8 Test1.

Comment 5 Valdis Kletnieks 2007-07-25 22:00:34 UTC
Confirming things are looking better - a few RPMs still haven't made it to my
local mirror yet, but enough have arrived already that Firefox now works again
(it broke due to gtk2.i386 libs issue).  Presumably the rest of the RPMs will
show up tomorrow.  Thanks for figuring out what it was, I'd never have guessed a
binutils bug. :)


Note You need to log in before you can comment on or make changes to this bug.