Bug 249445 - rpm dependency on lm_sensors needed by ksysguard
rpm dependency on lm_sensors needed by ksysguard
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-24 14:26 EDT by Philip Ashmore
Modified: 2014-01-21 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.2.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 14:47:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Ashmore 2007-07-24 14:26:04 EDT
Description of problem:
rpm dependency on lm_sensors needed by ksysguard

Version-Release number of selected component (if applicable):


How reproducible:
1 out of 1 times.

Steps to Reproduce:
1. Clean Install FC7 from DVD.
2.
3.
  
Actual results:
ksysguard is installed as part of kdebase but lm_sensors is not installed

Expected results:
kdebase should require lm_sensors.i386

Additional info:
running ksysguardd from konsole reports
ksysguardd: error while loading shared libraries: libsensors.so.3: cannot open
shared object file: No such file or directory

I ran "yum -y update" today but that didn't fix the problem either.
Comment 1 Ngo Than 2007-07-26 09:40:27 EDT
rpm -q --requires kdebase | grep sensor
libsensors.so.3

it sounds a bug in yum. kdebase already requires this.
Comment 2 Philip Ashmore 2007-07-26 11:20:49 EDT
By the way, I installed KDE after installing fc7 and enabling a local updates
repo. If fc7 had an option to use an attached disk containing an updates repo I
would have used that.

I got another bug - this time in kdemultimedia
This is cascading...
If I choose multimedia/KRec nothing happens.
If I right click the menu entry and select "Put into Run Dialog" I get a run
dialog containing
    krec %i %m -caption "%c"
If I run this from konsole I get

krec: error while loading shared libraries: libaudio.so.2: cannot open shared
object file: No such file or directory

I tracked this down to nas.i386 not being installed.
So I installed it. And then in konsole...

krec %i %m -caption "%c"
krec: error while loading shared libraries: libjack.so.0: cannot open shared
object file: No such file or directory

So I installed jack-audio-connection-kit. and then from konsole...

krec %i %m -caption "%c"
krec: Unexpected argument '%i'.
krec: Use --help to get a list of available command line options.

So the KDE menu system is presenting a command that doesn't work!!! If I press
"Run" from the run dialog now, nothing happens, but if I select it from
Multimedia/KRec it now works!
Comment 3 Philip Ashmore 2007-07-26 11:34:07 EDT
Something else that springs to mind.
After doing the DVD install I restored my home directory from backup - including
the ~.kde directory.
Then I installed KDE from the local updates repo.
Comment 4 Philip Ashmore 2007-07-26 11:38:18 EDT
Darn. Sorry for so many additions - I also noticed that hibernate is no longer
an option in KLaptop although it's selected as a configuration option - it was
available before I reinstalled fc7 -> kde from local updates repo.
Comment 5 Philip Ashmore 2007-07-29 15:27:54 EDT
I reinstalled F7 but this time included kde-desktop in my package selections.
I saw a script error right at the end, but this may be related to me having a
pcmcia network/modem card inserted.
Such script errors should find their way into install.log,

Otherwise the above problems didn't occur.

To check the media I copied the DVD to an .iso file with dd and made a backup.
    dd if=/dev/scd0 ~/F-7-i386-DVD.iso
    cp ~/F-7-i386-DVD.iso ~/F-7-i386-DVD.iso.orig
Then I rsync'd the .iso image with an internet repository .iso image to
synchronise them.
    rsync -a --partial --progress {rsync repo}/F-7-i386-DVD.iso ~/
Then I compared the newly sync'd .iso with the dd .iso backup.
    cmp -n 2900602880 ~/F-7-i386-DVD.iso ~/F-7-i386-DVD.iso.orig -l
Aside from F-7-i386-DVD.iso.orig file being a bit larger there were no
differences found.
Of course this doesn't prove that there wasn't a speck of dust or some other
data corruption present when I originally installed F7 but it does make a good
case that this wasn't a media problem.
Comment 6 Jeremy Katz 2007-09-13 14:47:58 EDT
This should be fixed with yum 3.2.5

Note You need to log in before you can comment on or make changes to this bug.