Bug 249470 - cn equality index missing by default
Summary: cn equality index missing by default
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: Database - Indexes/Searches (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Rich Megginson
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 240316
TreeView+ depends on / blocked
 
Reported: 2007-07-24 20:53 UTC by Chandrasekar Kannan
Modified: 2016-05-06 14:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-06 14:48:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs (3.60 KB, patch)
2007-07-24 23:54 UTC, Rich Megginson
no flags Details | Diff
cvs commit log (414 bytes, application/octet-stream)
2007-07-25 15:20 UTC, Rich Megginson
no flags Details

Description Chandrasekar Kannan 2007-07-24 20:53:33 UTC
cn equality index missing by default on any instance
created with DS 8.0

-----------------------------------------------------------
for example, with DS 7.1, you would see these,

[root@neo userRoot]# pwd
/opt/redhat-ds/slapd-neo/db/userRoot
[root@neo userRoot]# ls
aci.db4         cn.db4     entrydn.db4   nsUniqueId.db4       objectclass.db4
ancestorid.db4  DBVERSION  id2entry.db4  numsubordinates.db4  parentid.db4
[root@neo userRoot]#      

-----------------------------------------------------------
with DS 8.0, I see only these,

[root@margo userRoot]# pwd
/DS8.0-31081/server/slapd-margo/db/userRoot
[root@margo userRoot]# ls
aci.db4         DBVERSION    id2entry.db4    numsubordinates.db4  parentid.db4
ancestorid.db4  entrydn.db4  nsuniqueid.db4  objectclass.db4
[root@margo userRoot]#

-----------------------------------------------------------

Comment 1 Rich Megginson 2007-07-24 23:54:59 UTC
Created attachment 159896 [details]
diffs

Comment 2 Noriko Hosoi 2007-07-25 00:07:24 UTC
Your fix looks good.

Comment 3 Rich Megginson 2007-07-25 15:20:49 UTC
Created attachment 159938 [details]
cvs commit log

Reviewed by: nhosoi (Thanks!)
Fix Description: When creating the database instance during dse.ldif
processing, we do not create the user defined indexes from the defaults for
this backend. This used to work in the old setup code because that code would
always add the configuration for the indexes for the new instance.  The way it
is supposed to work is that a new instance should just copy the default indexes
for that backend.  This works fine when adding an instance via LDAP but not
during startup.  I just added a call to have this done during startup.	I also
removed some obsolete indexes from the default indexes.
Platforms tested: RHEL4
Flag Day: no
Doc impact: no

Comment 4 Anh Nguyen 2007-11-28 18:23:27 UTC
changed status to VERIFIED
[root@optimusvm7 userRoot]# ls
aci.db4         cn.db4     entrydn.db4   nsuniqueid.db4       objectclass.db4
ancestorid.db4  DBVERSION  id2entry.db4  numsubordinates.db4  parentid.db4



Note You need to log in before you can comment on or make changes to this bug.