Bug 249491 - can't login to gdm with account made by useradd
Summary: can't login to gdm with account made by useradd
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-25 01:56 UTC by Jens Petersen
Modified: 2013-01-10 04:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 05:23:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2007-07-25 01:56:22 UTC
Description of problem:
With recent rawhide (after 20070720?), I am unable to login from gdm as a user
to start a desktop session.

Version-Release number of selected component (if applicable):
gdm-2.19.4-1.fc8

How reproducible:
every time

Steps to Reproduce:
1. install fedora development
2. add a user (firstboot currently seems to crash)
3. try to login as user from gdm
  
Actual results:
3. Dialog appears:

Expected results:
login to work

Additional info:
Not sure if this is gdm's fault since it was last updated 10 July,
but I am able to start a desktop session without any problem with startx
from a console.

Comment 1 Jens Petersen 2007-07-27 00:18:53 UTC
Is this just me?

If not, looks like a f8t1 blocker to me...

Comment 2 Will Woods 2007-07-27 02:43:17 UTC
It works for me if you log in as root and add a user using system-config-users.
Adding a user with 'usermod' does *not* work - is that how you created the
normal user?

What's the difference between 'usermod -m' and account creation with
system-config-users?

Comment 3 Jens Petersen 2007-07-27 04:19:19 UTC
Yes, I used adduser, and you're right system-config-users works for me too.

Moving to shadow-utils.

Comment 4 Jens Petersen 2007-07-30 05:32:14 UTC
Sorry forgot to include the text from the dialog, but basically it is
to the affect: your home directory /home/user does not appear to exist.

(Normally I would make my account with firstboot but currently firstboot
is not coming up for me...)

Comment 5 Peter Vrabec 2007-07-30 12:29:25 UTC
I can't reproduce this problem and I don't suspect shadow-utils fault here. 
There wasn't many changes in shadow-utils last "days".

What shadow-utils and selinux-policy do you use? Is the anything important in 
logs? Could you provide "strace -f" of useradd.


Comment 6 Jesse Keating 2007-07-30 14:21:00 UTC
I can't replicate it either.  Dropping from F8Test1 tracker.

Comment 7 Jens Petersen 2007-07-31 03:04:39 UTC
Ok, could it be selinux perhaps?

Comment 8 Jens Petersen 2007-07-31 05:23:19 UTC
Indeed this seems to be fixed with the latest selinux-policy which
will be in test3 I think.


Note You need to log in before you can comment on or make changes to this bug.