Bug 249504 - Add alpha to 64 bit arches - ImageMagick
Add alpha to 64 bit arches - ImageMagick
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
alpha Linux
low Severity low
: ---
: ---
Assigned To: Norm Murray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 05:20 EDT by Oliver Falk
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: ImageMagick-6.3.5.9-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-23 20:33:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-07-25 05:20:29 EDT
Index: ImageMagick.spec
===================================================================
RCS file: /cvs/pkgs/devel/ImageMagick/ImageMagick.spec,v
retrieving revision 1.70
diff -u -p -r1.70 ImageMagick.spec
--- ImageMagick.spec    5 Apr 2007 12:18:29 -0000       1.70
+++ ImageMagick.spec    25 Jul 2007 09:18:17 -0000
@@ -178,7 +178,7 @@ rm -f  $RPM_BUILD_ROOT%{_libdir}/ImageMa
 rm -f  $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
 
 # fix multilib issues
-%ifarch x86_64 s390x ia64 ppc64
+%ifarch x86_64 s390x ia64 ppc64 alpha
 %define wordsize 64
 %else
 %define wordsize 32

This patch is untested, but it should work fine.


Else it would build the following:
[oliver@gosa ImageMagick]$ rpm -ql ImageMagick-devel|grep magick-config
/usr/include/magick/magick-config-32.h
/usr/include/magick/magick-config.h

But magick-config.h will include magick-config-64.h, since it checks for the
wordsize...
Comment 1 Norm Murray 2007-09-23 20:33:43 EDT
Added in ImageMagick-6.3.5.9-1.fc8

Note You need to log in before you can comment on or make changes to this bug.