Bug 24953 - rpm -F and multiple or deprecated versions of packages
Summary: rpm -F and multiple or deprecated versions of packages
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-25 19:10 UTC by Joe Harrington
Modified: 2007-04-18 16:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-15 04:52:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Harrington 2001-01-25 19:10:41 UTC
If I have several versions of a package on an rpm -Fvh command line, there
are often conflicts or dependency problems reported between the older and
newer versions of the same package.  rpm -F should first select the newest
version of each duplicate package from its command line and only then check
for conflicts and dependencies.

A common place for this to happen is when someone grabs the updates
directory from the Red Hat FTP server, which contains several versions of a
package, and does rpm -Fvh * in that directory.

Likewise, there should be a way for a package to say that it deprecates a
package of a different name.  For example, php-4.0.1pl1 contains the
previous php package and the previous mod_php package, both of which are
also updates to the release php and therefore in the Red Hat updates
directory.  php-4.0.1pl1 should be able to tell rpm that it obsoletes the
previous mod_php, even if the previous mod_php is on the same command line
(as it might be in the example above).

--jh--

Comment 1 Nick Urbanik 2001-01-27 06:26:31 UTC
Even when all the older packages are removed, rpm still requires manually
installing some packages first.  This was disappointing, since I went to the
trouble of writing a Perl program to move older packages to another directory.

For example, I had to install the mysql packages before I could install the php
packages; the dependencies should be sorted automatically.

Comment 2 Jeff Johnson 2002-07-20 19:01:17 UTC
rpm-4.1 handles duplicate packages on the
CLI, preferring the newest N-EVR (but not yet
arch scoring).

AFAIK, Obsoletes: works as you've asked.

And, finally, if you install the rpmdb-redhat
package, rpm-4.1 will suggest the next level
of packages that need to be added to the command.
Not yet a full blown dependency solver, but progress
no less.


Note You need to log in before you can comment on or make changes to this bug.